Update to version 0.23.4; Fixes RHBZ#2014620

epel10
Fabio Valentini 2 years ago
parent cbb45901e9
commit df5a2ab5b0
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/*.src.rpm
/tokio-rustls-0.22.0.crate
/tokio-rustls-0.23.4.crate

@ -1,27 +1,26 @@
# Generated by rust2rpm 17
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate tokio-rustls
Name: rust-%{crate}
Version: 0.22.0
Name: rust-tokio-rustls
Version: 0.23.4
Release: %autorelease
Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/tokio-rustls
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump rustls-pemfile dev-dependency from 0.2 to 1.0
Patch: tokio-rustls-fix-metadata.diff
ExclusiveArch: %{rust_arches}
# ring is not available on ppc64le and s390x
ExcludeArch: ppc64le s390x
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Asynchronous TLS/SSL streams for Tokio using Rustls.}
@ -34,13 +33,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -48,11 +48,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dangerous_configuration-devel
Summary: %{summary}
@ -60,11 +60,11 @@ BuildArch: noarch
%description -n %{name}+dangerous_configuration-devel %{_description}
This package contains library source intended for building other packages
which use "dangerous_configuration" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "dangerous_configuration" feature of the "%{crate}" crate.
%files -n %{name}+dangerous_configuration-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+early-data-devel
Summary: %{summary}
@ -72,11 +72,35 @@ BuildArch: noarch
%description -n %{name}+early-data-devel %{_description}
This package contains library source intended for building other packages
which use "early-data" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "early-data" feature of the "%{crate}" crate.
%files -n %{name}+early-data-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tls12-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tls12-devel %{_description}
This package contains library source intended for building other packages which
use the "tls12" feature of the "%{crate}" crate.
%files -n %{name}+tls12-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -95,7 +119,7 @@ which use "early-data" feature of "%{crate}" crate.
%check
# * skip tests that require an internet connection
# * skip tests that fail due to expired certificates
%cargo_test -- -- --skip test_tls12 --skip test_modern --skip test_stream::stream --skip pass
%cargo_test -- -- --skip common::test_stream::stream --skip test_modern --skip test_tls12 --skip pass --skip test_lazy_config_acceptor
%endif
%changelog

@ -1 +1 @@
SHA512 (tokio-rustls-0.22.0.crate) = cac6c5ebbdb751721f881f6e4c21e1b34ff8aea84256e25f92cecbeb30b6db3a6b2d78b7eeca253179b78a94c9226aff23492b0311d81ce27470ce939e675d0a
SHA512 (tokio-rustls-0.23.4.crate) = 92d9f5f94f8a81bb12e5923e08e9e185340351342ed167f23a9855d0c2e77089ae882c0c24faccfbf3c8f1033589a76281da42824e8447ce1b56c7a383f38b13

@ -0,0 +1,11 @@
--- tokio-rustls-0.23.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-rustls-0.23.4/Cargo.toml 2023-03-18T21:37:39.147173+00:00
@@ -43,7 +43,7 @@
version = "1"
[dev-dependencies.rustls-pemfile]
-version = "0.2.1"
+version = "1.0"
[dev-dependencies.tokio]
version = "1.0"
Loading…
Cancel
Save