Update to version 0.26.0; Fixes RHBZ#2252920

epel10
Fabio Valentini 8 months ago
parent f0ed26cefd
commit 2f477140c1
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -5,3 +5,4 @@
/tokio-rustls-0.23.4.crate /tokio-rustls-0.23.4.crate
/tokio-rustls-0.24.1.crate /tokio-rustls-0.24.1.crate
/tokio-rustls-0.25.0.crate /tokio-rustls-0.25.0.crate
/tokio-rustls-0.26.0.crate

@ -5,7 +5,7 @@
%global crate tokio-rustls %global crate tokio-rustls
Name: rust-tokio-rustls Name: rust-tokio-rustls
Version: 0.25.0 Version: 0.26.0
Release: %autorelease Release: %autorelease
Summary: Asynchronous TLS/SSL streams for Tokio using Rustls Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
@ -13,6 +13,9 @@ Summary: Asynchronous TLS/SSL streams for Tokio using Rustls
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/tokio-rustls URL: https://crates.io/crates/tokio-rustls
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * default to "ring" crypto backend and drop "aws-lc-rs" backend
Patch: tokio-rustls-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 24
@ -112,7 +115,7 @@ use the "tls12" feature of the "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
# * skip tests that require internet access # * skip tests that require internet access
%cargo_test -- -- --exact --skip common::test_stream::stream_handshake_regression_issues_77 --skip test_modern --skip test_tls12 %cargo_test -- -- --exact --skip common::test_stream::stream_handshake_regression_issues_77 --skip test_modern --skip test_tls12 --skip test_modern_vectored --skip test_tls12_vectored
%endif %endif
%changelog %changelog

@ -1,8 +1,15 @@
[package]
cargo-toml-patch-comments = [
"default to \"ring\" crypto backend and drop \"aws-lc-rs\" backend",
]
[tests] [tests]
skip = [ skip = [
"common::test_stream::stream_handshake_regression_issues_77", "common::test_stream::stream_handshake_regression_issues_77",
"test_modern", "test_modern",
"test_tls12", "test_tls12",
"test_tls12_vectored",
"test_modern_vectored",
] ]
skip-exact = true skip-exact = true
comments = ["skip tests that require internet access"] comments = ["skip tests that require internet access"]

@ -1 +1 @@
SHA512 (tokio-rustls-0.25.0.crate) = 4e04669ecdd8235edd438075e6b125f6473e117adc2ae13ceaee7668705e81a87f97242253f51dea204fa1bb3b9f8f9f21b587b4edc7c2e58e375f5537ee5f95 SHA512 (tokio-rustls-0.26.0.crate) = 101f2083e04feffec48204388c4be3d51fd6dc45bdd04bb75bdfaba48cbdd89529e14dda194ef45b2d78530cc74f128a763fb09165a52d738eb17adff7c56664

@ -0,0 +1,19 @@
--- tokio-rustls-0.26.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tokio-rustls-0.26.0/Cargo.toml 2024-06-28T09:37:31.568922+00:00
@@ -63,15 +63,12 @@
version = "0.26"
[features]
-aws-lc-rs = ["aws_lc_rs"]
-aws_lc_rs = ["rustls/aws_lc_rs"]
default = [
"logging",
"tls12",
- "aws_lc_rs",
+ "ring",
]
early-data = []
-fips = ["rustls/fips"]
logging = ["rustls/logging"]
ring = ["rustls/ring"]
tls12 = ["rustls/tls12"]
Loading…
Cancel
Save