Update to version 1.6.1; Fixes RHBZ#2294183

epel10
Fabio Valentini 8 months ago
parent 844fb1fdba
commit 83e3a2aa7f
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/tinyvec-1.5.0.crate /tinyvec-1.5.0.crate
/tinyvec-1.5.1.crate /tinyvec-1.5.1.crate
/tinyvec-1.6.0.crate /tinyvec-1.6.0.crate
/tinyvec-1.6.1.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 26
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate tinyvec %global crate tinyvec
Name: rust-tinyvec Name: rust-tinyvec
Version: 1.6.0 Version: 1.6.1
Release: %autorelease Release: %autorelease
Summary: 100% safe vec-like data structures Summary: 100% safe vec-like data structures
@ -13,10 +13,11 @@ License: Zlib OR Apache-2.0 OR MIT
URL: https://crates.io/crates/tinyvec URL: https://crates.io/crates/tinyvec
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds # * drop unused debugger_visualizer support
# * drop unused, benchmark-only criterion dev-dependency
Patch: tinyvec-fix-metadata.diff Patch: tinyvec-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
`tinyvec` provides 100% safe vec-like data structures.} `tinyvec` provides 100% safe vec-like data structures.}
@ -185,7 +186,7 @@ use the "tinyvec_macros" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -1 +1 @@
SHA512 (tinyvec-1.6.0.crate) = e5acaf353c58c60ae5556130a934f1048abb79cf6668ae467d308bac44b689d8a9997227ea879f4b5fe50f29cde8761801b088d7149bcd063b973056c381921c SHA512 (tinyvec-1.6.1.crate) = fc00617fe56c438ed417b9c18fb2525e624b6b6effd1b729da9b8f144b36cd02dbcefbbb6fd423c30b1f19309d42117a1eaab99deb0a46b2a474c2cdc02c1695

@ -1,33 +1,61 @@
--- tinyvec-1.6.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- tinyvec-1.6.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ tinyvec-1.6.0/Cargo.toml 2023-08-07T18:29:35.290442+00:00 +++ tinyvec-1.6.1/Cargo.toml 2024-06-27T12:30:23.023691+00:00
@@ -27,6 +27,12 @@ @@ -77,29 +77,8 @@
] ]
license = "Zlib OR Apache-2.0 OR MIT"
repository = "https://github.com/Lokathor/tinyvec"
+exclude = [
+ "/src-backup",
+ "/compare_benchmarks.py",
+ "/gen-array-impls.sh",
+ "/rustfmt.toml",
+]
[package.metadata.docs.rs] [[test]]
features = [ -name = "debugger_visualizer"
@@ -91,9 +97,6 @@ -path = "tests/debugger_visualizer.rs"
-test = false
-required-features = ["debugger_visualizer"]
-
-[[test]]
name = "arrayvec"
path = "tests/arrayvec.rs"
-
-[[bench]]
-name = "macros"
-path = "benches/macros.rs"
-harness = false
-required-features = ["alloc"]
-
-[[bench]]
-name = "smallvec"
-path = "benches/smallvec.rs"
-harness = false
-required-features = [
- "alloc",
- "real_blackbox",
-]
[dependencies.arbitrary]
version = "1"
@@ -114,15 +93,6 @@
version = "0.1" version = "0.1"
optional = true optional = true
-[dev-dependencies.criterion] -[dev-dependencies.criterion]
-version = "0.3.0" -version = "0.3.0"
-
-[dev-dependencies.debugger_test]
-version = "0.1"
-
-[dev-dependencies.debugger_test_parser]
-version = "0.1"
- -
[dev-dependencies.serde_test] [dev-dependencies.serde_test]
version = "1.0" version = "1.0"
@@ -106,7 +109,6 @@ @@ -131,12 +101,10 @@
[features]
alloc = ["tinyvec_macros"]
-debugger_visualizer = []
default = []
experimental_write_impl = [] experimental_write_impl = []
grab_spare_slice = [] grab_spare_slice = []
nightly_slice_partition_dedup = [] nightly_slice_partition_dedup = []
-real_blackbox = ["criterion/real_blackbox"] -real_blackbox = ["criterion/real_blackbox"]
rustc_1_40 = [] rustc_1_40 = []
rustc_1_55 = ["rustc_1_40"] rustc_1_55 = []
rustc_1_57 = ["rustc_1_55"] rustc_1_57 = ["rustc_1_55"]

Loading…
Cancel
Save