parent
844fb1fdba
commit
83e3a2aa7f
@ -1 +1 @@
|
||||
SHA512 (tinyvec-1.6.0.crate) = e5acaf353c58c60ae5556130a934f1048abb79cf6668ae467d308bac44b689d8a9997227ea879f4b5fe50f29cde8761801b088d7149bcd063b973056c381921c
|
||||
SHA512 (tinyvec-1.6.1.crate) = fc00617fe56c438ed417b9c18fb2525e624b6b6effd1b729da9b8f144b36cd02dbcefbbb6fd423c30b1f19309d42117a1eaab99deb0a46b2a474c2cdc02c1695
|
||||
|
@ -1,33 +1,61 @@
|
||||
--- tinyvec-1.6.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tinyvec-1.6.0/Cargo.toml 2023-08-07T18:29:35.290442+00:00
|
||||
@@ -27,6 +27,12 @@
|
||||
--- tinyvec-1.6.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ tinyvec-1.6.1/Cargo.toml 2024-06-27T12:30:23.023691+00:00
|
||||
@@ -77,29 +77,8 @@
|
||||
]
|
||||
license = "Zlib OR Apache-2.0 OR MIT"
|
||||
repository = "https://github.com/Lokathor/tinyvec"
|
||||
+exclude = [
|
||||
+ "/src-backup",
|
||||
+ "/compare_benchmarks.py",
|
||||
+ "/gen-array-impls.sh",
|
||||
+ "/rustfmt.toml",
|
||||
+]
|
||||
|
||||
[package.metadata.docs.rs]
|
||||
features = [
|
||||
@@ -91,9 +97,6 @@
|
||||
[[test]]
|
||||
-name = "debugger_visualizer"
|
||||
-path = "tests/debugger_visualizer.rs"
|
||||
-test = false
|
||||
-required-features = ["debugger_visualizer"]
|
||||
-
|
||||
-[[test]]
|
||||
name = "arrayvec"
|
||||
path = "tests/arrayvec.rs"
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "macros"
|
||||
-path = "benches/macros.rs"
|
||||
-harness = false
|
||||
-required-features = ["alloc"]
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "smallvec"
|
||||
-path = "benches/smallvec.rs"
|
||||
-harness = false
|
||||
-required-features = [
|
||||
- "alloc",
|
||||
- "real_blackbox",
|
||||
-]
|
||||
|
||||
[dependencies.arbitrary]
|
||||
version = "1"
|
||||
@@ -114,15 +93,6 @@
|
||||
version = "0.1"
|
||||
optional = true
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3.0"
|
||||
-
|
||||
-[dev-dependencies.debugger_test]
|
||||
-version = "0.1"
|
||||
-
|
||||
-[dev-dependencies.debugger_test_parser]
|
||||
-version = "0.1"
|
||||
-
|
||||
[dev-dependencies.serde_test]
|
||||
version = "1.0"
|
||||
|
||||
@@ -106,7 +109,6 @@
|
||||
@@ -131,12 +101,10 @@
|
||||
|
||||
[features]
|
||||
alloc = ["tinyvec_macros"]
|
||||
-debugger_visualizer = []
|
||||
default = []
|
||||
experimental_write_impl = []
|
||||
grab_spare_slice = []
|
||||
nightly_slice_partition_dedup = []
|
||||
-real_blackbox = ["criterion/real_blackbox"]
|
||||
rustc_1_40 = []
|
||||
rustc_1_55 = ["rustc_1_40"]
|
||||
rustc_1_55 = []
|
||||
rustc_1_57 = ["rustc_1_55"]
|
||||
|
Loading…
Reference in new issue