Initial import (#2238567)

epel9 imports/e9/rust-timeago-0.4.2-1.el9
Fabio Valentini 1 year ago
parent c88c9be691
commit e20d102d89
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/timeago-0.4.2.crate

@ -1,3 +0,0 @@
# rust-timeago
The rust-timeago package

@ -0,0 +1,98 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate timeago
Name: rust-timeago
Version: 0.4.2
Release: %autorelease
Summary: Given a Duration, lossily format it like in 'N days ago'
License: MIT OR Apache-2.0
URL: https://crates.io/crates/timeago
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * prevent unwanted binary from being built and shipped
# * remove unused support for ISO 639 language codes
Patch: timeago-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Given a Duration, lossily format it like in 'N days ago'. Parsing it
back to Duration is not supported yet.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+translations-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+translations-devel %{_description}
This package contains library source intended for building other packages which
use the "translations" feature of the "%{crate}" crate.
%files -n %{name}+translations-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (timeago-0.4.2.crate) = f1f8c63b4f42463068478d3eac661d0431204ca65ca0a63d29d93af587c40a4c4912e3f027e37dc3344591e30362d49fb3b770a14ac0d8120d8e08fd5fe97e4c

@ -0,0 +1,25 @@
--- timeago-0.4.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ timeago-0.4.2/Cargo.toml 2023-09-18T21:46:53.398582+00:00
@@ -18,6 +18,7 @@
readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/vi/timeago"
+autobins = false
[package.metadata.docs.rs]
features = [
@@ -30,14 +31,9 @@
version = "0.4"
optional = true
-[dependencies.isolang]
-version = "2"
-optional = true
-
[features]
default = [
"translations",
- "isolang",
"chrono",
]
translations = []
Loading…
Cancel
Save