Initial import (time 0.2 compat package)

epel9
Fabio Valentini 3 years ago
parent 2b5cbe4263
commit 60caf57bec
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

4
.gitignore vendored

@ -0,0 +1,4 @@
/results_*/
/*.src.rpm
/time-0.2.27.crate

@ -1,3 +0,0 @@
# rust-time0.2
The rust-time0.2 package

@ -0,0 +1,150 @@
# Generated by rust2rpm 18
%bcond_without check
%global debug_package %{nil}
%global crate time
Name: rust-%{crate}0.2
Version: 0.2.27
Release: %autorelease
Summary: Date and time library
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/time
Source: %{crates_source}
# Initial patched metadata
# * drop windows- and WASM-specific dependencies
Patch0: time-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand:
Date and time library. Fully interoperable with the standard library. Mostly
compatible with #![no_std].}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-Apache
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+deprecated-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deprecated-devel %{_description}
This package contains library source intended for building other packages
which use "deprecated" feature of "%{crate}" crate.
%files -n %{name}+deprecated-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+panicking-api-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+panicking-api-devel %{_description}
This package contains library source intended for building other packages
which use "panicking-api" feature of "%{crate}" crate.
%files -n %{name}+panicking-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages
which use "rand" feature of "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (time-0.2.27.crate) = a54421ebb3b4b833fe5122bfbdb8d7e1fe2d605afcc252a1106183d148e5fc298e29d86284827a4545beee0810b8b756aff66eba03bc9a27e8686d5683e0f13b

@ -0,0 +1,19 @@
--- time-0.2.27/Cargo.toml 1970-01-01T00:00:00+00:00
+++ time-0.2.27/Cargo.toml 2021-11-18T12:38:26.252737+00:00
@@ -64,15 +64,7 @@
default = ["deprecated", "std"]
deprecated = []
panicking-api = []
-std = ["libc", "winapi", "stdweb", "standback/std"]
-[target."cfg(target_arch = \"wasm32\")".dependencies.stdweb]
-version = "0.4.20"
-optional = true
-default-features = false
+std = ["libc", "standback/std"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.89"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["minwinbase", "minwindef", "timezoneapi"]
-optional = true
Loading…
Cancel
Save