import rust-time0.2-0.2.27-5.el9

i9ce changed/i9ce/rust-time0.2-0.2.27-5.el9
Arkady L. Shane 1 year ago
commit 1e277c99a3
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,24 @@
From 639f0aca75b0dadaedf84520bc46b87c6c3e210e Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Thu, 8 Jun 2023 15:25:24 +0200
Subject: [PATCH] deny(warnings) considered harmful
---
src/lib.rs | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/lib.rs b/src/lib.rs
index 22fadd5..ce843a6 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -173,7 +173,6 @@
)]
#![doc(html_favicon_url = "https://avatars0.githubusercontent.com/u/55999857")]
#![doc(html_logo_url = "https://avatars0.githubusercontent.com/u/55999857")]
-#![doc(test(attr(deny(warnings))))]
#[cfg(not(feature = "std"))]
extern crate alloc;
--
2.40.1

Binary file not shown.

@ -0,0 +1,19 @@
--- time-0.2.27/Cargo.toml 1970-01-01T00:00:00+00:00
+++ time-0.2.27/Cargo.toml 2023-06-08T13:23:54.482950+00:00
@@ -64,15 +64,7 @@
default = ["deprecated", "std"]
deprecated = []
panicking-api = []
-std = ["libc", "winapi", "stdweb", "standback/std"]
-[target."cfg(target_arch = \"wasm32\")".dependencies.stdweb]
-version = "0.4.20"
-optional = true
-default-features = false
+std = ["libc", "stdweb", "standback/std"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.89"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["minwinbase", "minwindef", "timezoneapi"]
-optional = true

@ -0,0 +1,11 @@
--- time-0.2.27/Cargo.toml 1970-01-01T00:00:00+00:00
+++ time-0.2.27/Cargo.toml 2023-06-08T13:24:21.796057+00:00
@@ -64,7 +64,7 @@
default = ["deprecated", "std"]
deprecated = []
panicking-api = []
-std = ["libc", "stdweb", "standback/std"]
+std = ["libc", "standback/std"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.89"
optional = true

@ -0,0 +1,175 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 5;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate time
Name: rust-time0.2
Version: 0.2.27
Release: %autorelease
Summary: Date and time library
License: MIT OR Apache-2.0
URL: https://crates.io/crates/time
Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch: time-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop windows- and WASM-specific dependencies
Patch: time-fix-metadata.diff
Patch: 0001-deny-warnings-considered-harmful.patch
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Date and time library. Fully interoperable with the standard library.
Mostly compatible with #![no_std].}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-Apache
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deprecated-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deprecated-devel %{_description}
This package contains library source intended for building other packages which
use the "deprecated" feature of the "%{crate}" crate.
%files -n %{name}+deprecated-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+panicking-api-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+panicking-api-devel %{_description}
This package contains library source intended for building other packages which
use the "panicking-api" feature of the "%{crate}" crate.
%files -n %{name}+panicking-api-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.27-5
- Rebuilt for MSVSphere 9.3
* Thu Jun 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.27-5
- Allow warnings in doctests to fix tests with Rust 1.70
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.27-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.27-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.27-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Thu Nov 18 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.27-1
- Initial import (time 0.2 compat package)
Loading…
Cancel
Save