Update to version 0.1.45

epel9 imports/e9/rust-time0.1-0.1.45-1.el9
Fabio Valentini 2 years ago
parent 401ece7cce
commit fe8c7e4fb7
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -5,3 +5,4 @@
/time-0.1.42.crate
/time-0.1.43.crate
/time-0.1.44.crate
/time-0.1.45.crate

@ -1,28 +1,25 @@
# Generated by rust2rpm 13
%bcond_with check
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate time
Name: rust-%{crate}0.1
Version: 0.1.44
Name: rust-time0.1
Version: 0.1.45
Release: %autorelease
Summary: Utilities for working with time-related functions in Rust
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/time
Source: %{crates_source}
# Initial patched metadata
# * No windows/redox
Patch0: time-fix-metadata.diff
# Automatically generated patch to strip foreign dependencies
Patch: time-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * disable windows-specific dev-dependencies
Patch: time-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Utilities for working with time-related functions in Rust.}
@ -35,13 +32,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -49,11 +47,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc-serialize-devel
Summary: %{summary}
@ -61,11 +59,11 @@ BuildArch: noarch
%description -n %{name}+rustc-serialize-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-serialize" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "rustc-serialize" feature of the "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (time-0.1.44.crate) = 736a38637be0193a06fa35d42b4873b04a0a35d84cd2af85b7f653a1b67b95078577134bb187b777730e73cce67f437b45ff5c72b8e3f1f8e2ed3420ea0324cf
SHA512 (time-0.1.45.crate) = e643fb8649f3efdaa1b0b6abc6a140d55ac550a55cad99d0cce9415dc51e155fb1ea240953eeaba5dc47ec73c49ab7f2962af79c693436289de0eb3ff60985ee

@ -0,0 +1,20 @@
--- time-0.1.45/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.1.45/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -44,17 +44,3 @@
"winbase",
]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
-version = "=0.10.0"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.0"
-features = [
- "std",
- "minwinbase",
- "minwindef",
- "ntdef",
- "profileapi",
- "sysinfoapi",
- "timezoneapi",
-]

@ -1,15 +1,15 @@
--- time-0.1.44/Cargo.toml 2020-08-26T20:49:45+00:00
+++ time-0.1.44/Cargo.toml 2020-09-01T03:05:46.576294+00:00
@@ -29,12 +29,3 @@
optional = true
--- time-0.1.45/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.1.45/Cargo.toml 2022-12-23T22:29:19.302372+00:00
@@ -35,12 +35,3 @@
[dev-dependencies.log]
version = "0.4"
-
-[dev-dependencies.winapi]
-version = "0.3.0"
-features = ["std", "processthreadsapi", "winbase"]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
-version = "=0.10.0"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.0"
-features = ["std", "minwinbase", "minwindef", "ntdef", "profileapi", "sysinfoapi", "timezoneapi"]
-features = [
- "std",
- "processthreadsapi",
- "winbase",
-]
-

Loading…
Cancel
Save