Update to 0.2.7

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent d7e0e56e83
commit e72267731b
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -4,3 +4,4 @@
/time-0.1.41.crate /time-0.1.41.crate
/time-0.1.42.crate /time-0.1.42.crate
/time-0.2.6.crate /time-0.2.6.crate
/time-0.2.7.crate

@ -5,16 +5,16 @@
%global crate time %global crate time
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.2.6 Version: 0.2.7
Release: 1%{?dist} Release: 1%{?dist}
Summary: Utilities for working with time-related functions in Rust Summary: Date and time library
# Upstream license specification: MIT OR Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/time URL: https://crates.io/crates/time
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Exclude CI files # * No windows
Patch0: time-fix-metadata.diff Patch0: time-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -41,7 +41,7 @@ which use "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-Apache %license LICENSE-MIT LICENSE-Apache
%doc README.md %doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
@ -56,6 +56,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+__doc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+__doc-devel %{_description}
This package contains library source intended for building other packages
which use "__doc" feature of "%{crate}" crate.
%files -n %{name}+__doc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+deprecated-devel %package -n %{name}+deprecated-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -68,6 +80,18 @@ which use "deprecated" feature of "%{crate}" crate.
%files -n %{name}+deprecated-devel %files -n %{name}+deprecated-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+panicking-api-devel %package -n %{name}+panicking-api-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -80,6 +104,18 @@ which use "panicking-api" feature of "%{crate}" crate.
%files -n %{name}+panicking-api-devel %files -n %{name}+panicking-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages
which use "rand" feature of "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -106,7 +142,6 @@ which use "std" feature of "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
sed -i -e '/#!\[.*deny(warnings).*\]/d' src/lib.rs
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
@ -124,6 +159,9 @@ sed -i -e '/#!\[.*deny(warnings).*\]/d' src/lib.rs
%endif %endif
%changelog %changelog
* Sun Feb 23 10:26:00 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.2.7-1
- Update to 0.2.7
* Wed Feb 12 2020 Josh Stone <jistone@redhat.com> - 0.2.6-1 * Wed Feb 12 2020 Josh Stone <jistone@redhat.com> - 0.2.6-1
- Update to 0.2.6 - Update to 0.2.6

@ -1 +1 @@
SHA512 (time-0.2.6.crate) = a9139d0a1bc8128646a0914b936da1f9b2711da9eb8c894349b11741abd0c7eeda585739dbe257e5d845f9b4ca78315dc6adfa41b7c33b5d45ca98fe4cc7184e SHA512 (time-0.2.7.crate) = 9788c08d4d4a4ca54c85d13d9def2b2cf0f729041710c97d2c9f552f3094b4cc657d4f192dae375c5d63d63098c15c7ee0ea260249dcfa65d7491106f976fb80

@ -1,10 +1,15 @@
--- time-0.2.6/Cargo.toml 2020-01-30T03:36:54+00:00 --- time-0.2.7/Cargo.toml 2020-02-22T21:35:55+00:00
+++ time-0.2.6/Cargo.toml 2020-02-12T18:16:29.707889+00:00 +++ time-0.2.7/Cargo.toml 2020-02-23T09:26:00.240856+00:00
@@ -21,6 +21,7 @@ @@ -45,11 +45,7 @@
categories = ["date-and-time"] default = ["deprecated", "std"]
license = "MIT OR Apache-2.0" deprecated = []
repository = "https://github.com/time-rs/time" panicking-api = []
+exclude = ["/.github"] -std = ["libc", "winapi"]
[package.metadata.docs.rs] +std = ["libc"]
all-features = true [target."cfg(unix)".dependencies.libc]
[dependencies.rustversion] version = "0.2"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["minwinbase", "minwindef", "timezoneapi"]
-optional = true

Loading…
Cancel
Save