Update to version 0.3.37; Fixes RHBZ#2330138

epel10 imports/epel10/rust-time-0.3.37-1.el10
Fabio Valentini 3 months ago
parent cdaac5cbe7
commit deee95accb
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -33,3 +33,4 @@
/time-0.3.31.crate /time-0.3.31.crate
/time-0.3.34.crate /time-0.3.34.crate
/time-0.3.36.crate /time-0.3.36.crate
/time-0.3.37.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 26 # Generated by rust2rpm 27
%bcond_without check %bcond check 1
%global debug_package %{nil} %global debug_package %{nil}
%global crate time %global crate time
Name: rust-time Name: rust-time
Version: 0.3.36 Version: 0.3.37
Release: %autorelease Release: %autorelease
Summary: Date and time library Summary: Date and time library

@ -1 +1 @@
SHA512 (time-0.3.36.crate) = 83da6e27691d1f0ef37ed276528e927686a06dab4811b6e29d625ef7a0f7c30fbb86896d74a2b087726e7a24a951b0a83aa1f5f22d711ead54f447d36ac47133 SHA512 (time-0.3.37.crate) = 6d007507f79c45a7408675b3223bbf83a133bbaf96429ae6a02b5db09acccf884bb8323dc6f3dd05e7ce87a78366a55bafa6c6ba31b04198a31026df4ef425e2

@ -1,6 +1,6 @@
--- time-0.3.36/Cargo.toml 1970-01-01T00:00:01+00:00 --- time-0.3.37/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.3.36/Cargo.toml 2024-11-15T16:49:54.222829+00:00 +++ time-0.3.37/Cargo.toml 2024-12-08T18:20:11.323118+00:00
@@ -175,18 +175,7 @@ @@ -170,18 +170,7 @@
"alloc", "alloc",
"deranged/std", "deranged/std",
] ]
@ -9,7 +9,7 @@
-[target."cfg(__ui_tests)".dev-dependencies.trybuild] -[target."cfg(__ui_tests)".dev-dependencies.trybuild]
-version = "1.0.68" -version = "1.0.68"
- -
-[target."cfg(all(target_family = \"wasm\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys] -[target.'cfg(all(target_family = "wasm", not(any(target_os = "emscripten", target_os = "wasi"))))'.dependencies.js-sys]
-version = "0.3.58" -version = "0.3.58"
-optional = true -optional = true
- -
@ -18,9 +18,9 @@
-default-features = false -default-features = false
+wasm-bindgen = [] +wasm-bindgen = []
[target."cfg(target_family = \"unix\")".dependencies.libc] [target.'cfg(target_family = "unix")'.dependencies.libc]
version = "0.2.98" version = "0.2.98"
@@ -279,3 +268,4 @@ @@ -291,3 +280,4 @@
[lints.rustdoc] [lints.rustdoc]
private-doc-tests = "warn" private-doc-tests = "warn"
unescaped-backticks = "warn" unescaped-backticks = "warn"

@ -1,40 +1,10 @@
--- time-0.3.36/Cargo.toml 1970-01-01T00:00:01+00:00 --- time-0.3.37/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.3.36/Cargo.toml 2024-11-15T16:51:13.742970+00:00 +++ time-0.3.37/Cargo.toml 2024-12-08T18:20:27.319203+00:00
@@ -53,15 +53,6 @@ @@ -170,7 +170,6 @@
[lib]
bench = false
-[[test]]
-name = "tests"
-path = "../tests/main.rs"
-
-[[bench]]
-name = "benchmarks"
-path = "../benchmarks/main.rs"
-harness = false
-
[dependencies.deranged]
version = "0.3.9"
features = ["powerfmt"]
@@ -111,11 +102,11 @@
default-features = false
[dev-dependencies.rstest]
-version = "0.18.2"
+version = ">=0.18.2, <0.24.0"
default-features = false
[dev-dependencies.rstest_reuse]
-version = "0.6.0"
+version = ">=0.6.0, <0.8.0"
[dev-dependencies.serde]
version = "1.0.184"
@@ -175,7 +166,6 @@
"alloc", "alloc",
"deranged/std", "deranged/std",
] ]
-wasm-bindgen = [] -wasm-bindgen = []
[target."cfg(target_family = \"unix\")".dependencies.libc] [target.'cfg(target_family = "unix")'.dependencies.libc]
version = "0.2.98" version = "0.2.98"

Loading…
Cancel
Save