Update to 0.2.6

epel9
Josh Stone 5 years ago
parent 3f0cd44242
commit d7e0e56e83

1
.gitignore vendored

@ -3,3 +3,4 @@
/time-0.1.40.crate
/time-0.1.41.crate
/time-0.1.42.crate
/time-0.2.6.crate

@ -1,21 +1,20 @@
# Generated by rust2rpm 10
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}
%global crate time
Name: rust-%{crate}
Version: 0.1.42
Release: 8%{?dist}
Version: 0.2.6
Release: 1%{?dist}
Summary: Utilities for working with time-related functions in Rust
# Upstream license specification: MIT/Apache-2.0
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/time
Source: %{crates_source}
# Initial patched metadata
# * No windows/redox
# * Exclude CI files, https://github.com/rust-lang-deprecated/time/pull/170
# * Exclude CI files
Patch0: time-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -26,7 +25,8 @@ BuildArch: noarch
BuildRequires: rust-packaging
%global _description %{expand:
Utilities for working with time-related functions in Rust.}
Date and time library. Fully interoperable with the standard library. Mostly
compatible with #![no_std].}
%description %{_description}
@ -40,9 +40,9 @@ This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%license LICENSE-MIT LICENSE-Apache
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -54,19 +54,55 @@ This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc-serialize-devel
%package -n %{name}+deprecated-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc-serialize-devel %{_description}
%description -n %{name}+deprecated-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-serialize" feature of "%{crate}" crate.
which use "deprecated" feature of "%{crate}" crate.
%files -n %{name}+rustc-serialize-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%files -n %{name}+deprecated-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+panicking-api-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+panicking-api-devel %{_description}
This package contains library source intended for building other packages
which use "panicking-api" feature of "%{crate}" crate.
%files -n %{name}+panicking-api-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
@ -88,6 +124,9 @@ sed -i -e '/#!\[.*deny(warnings).*\]/d' src/lib.rs
%endif
%changelog
* Wed Feb 12 2020 Josh Stone <jistone@redhat.com> - 0.2.6-1
- Update to 0.2.6
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.42-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (time-0.1.42.crate) = 4df662212377093b0fd8fcd88ddc30b20a8af7d989c2e100c0cf64f9741e88eea6e858e1aa4220be6b76b0cf8b62c8116b492010d74d1ebef197c66aa130aa83
SHA512 (time-0.2.6.crate) = a9139d0a1bc8128646a0914b936da1f9b2711da9eb8c894349b11741abd0c7eeda585739dbe257e5d845f9b4ca78315dc6adfa41b7c33b5d45ca98fe4cc7184e

@ -1,25 +1,10 @@
--- time-0.1.42/Cargo.toml 1970-01-01T00:00:00+00:00
+++ time-0.1.42/Cargo.toml 2019-06-21T20:09:19.610502+00:00
@@ -19,6 +19,7 @@
documentation = "https://doc.rust-lang.org/time"
license = "MIT/Apache-2.0"
repository = "https://github.com/rust-lang/time"
+exclude = ["/.travis.yml", "/appveyor.yml"]
[dependencies.libc]
version = "0.2.1"
@@ -28,14 +29,6 @@
[dev-dependencies.log]
version = "0.4"
-[dev-dependencies.winapi]
-version = "0.3.0"
-features = ["std", "processthreadsapi", "winbase"]
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.1"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.0"
-features = ["std", "minwinbase", "minwindef", "ntdef", "profileapi", "sysinfoapi", "timezoneapi"]
[badges.appveyor]
repository = "alexcrichton/time"
--- time-0.2.6/Cargo.toml 2020-01-30T03:36:54+00:00
+++ time-0.2.6/Cargo.toml 2020-02-12T18:16:29.707889+00:00
@@ -21,6 +21,7 @@
categories = ["date-and-time"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/time-rs/time"
+exclude = ["/.github"]
[package.metadata.docs.rs]
all-features = true
[dependencies.rustversion]

Loading…
Cancel
Save