Update to version 0.3.5; Fixes RHBZ#1988247

epel9
Fabio Valentini 3 years ago
parent fd7ec533b0
commit b3f7ebf81c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -14,3 +14,4 @@
/time-0.2.24.crate
/time-0.2.25.crate
/time-0.2.26.crate
/time-0.3.5.crate

@ -1,11 +1,12 @@
# Generated by rust2rpm 16
%bcond_without check
# Generated by rust2rpm 18
# * unit tests are excluded from published crates
%bcond_with check
%global debug_package %{nil}
%global crate time
Name: rust-%{crate}
Version: 0.2.26
Version: 0.3.5
Release: %autorelease
Summary: Date and time library
@ -14,7 +15,7 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/time
Source: %{crates_source}
# Initial patched metadata
# * No windows or wasm
# * drop internal and benchmark-only dependencies
Patch0: time-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -41,7 +42,7 @@ which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-Apache
%doc README.md CHANGELOG.md
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -56,40 +57,112 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+deprecated-devel
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deprecated-devel %{_description}
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "deprecated" feature of "%{crate}" crate.
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+deprecated-devel
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel
%package -n %{name}+formatting-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
%description -n %{name}+formatting-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
which use "formatting" feature of "%{crate}" crate.
%files -n %{name}+libc-devel
%files -n %{name}+formatting-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+panicking-api-devel
%package -n %{name}+itoa-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+panicking-api-devel %{_description}
%description -n %{name}+itoa-devel %{_description}
This package contains library source intended for building other packages
which use "panicking-api" feature of "%{crate}" crate.
which use "itoa" feature of "%{crate}" crate.
%files -n %{name}+panicking-api-devel
%files -n %{name}+itoa-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+large-dates-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+large-dates-devel %{_description}
This package contains library source intended for building other packages
which use "large-dates" feature of "%{crate}" crate.
%files -n %{name}+large-dates-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+local-offset-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+local-offset-devel %{_description}
This package contains library source intended for building other packages
which use "local-offset" feature of "%{crate}" crate.
%files -n %{name}+local-offset-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages
which use "macros" feature of "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+parsing-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parsing-devel %{_description}
This package contains library source intended for building other packages
which use "parsing" feature of "%{crate}" crate.
%files -n %{name}+parsing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+quickcheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quickcheck-devel %{_description}
This package contains library source intended for building other packages
which use "quickcheck" feature of "%{crate}" crate.
%files -n %{name}+quickcheck-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+quickcheck-dep-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quickcheck-dep-devel %{_description}
This package contains library source intended for building other packages
which use "quickcheck-dep" feature of "%{crate}" crate.
%files -n %{name}+quickcheck-dep-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rand-devel
@ -116,6 +189,18 @@ which use "serde" feature of "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-human-readable-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-human-readable-devel %{_description}
This package contains library source intended for building other packages
which use "serde-human-readable" feature of "%{crate}" crate.
%files -n %{name}+serde-human-readable-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
@ -128,6 +213,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+time-macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-macros-devel %{_description}
This package contains library source intended for building other packages
which use "time-macros" feature of "%{crate}" crate.
%files -n %{name}+time-macros-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

@ -1 +1 @@
SHA512 (time-0.2.26.crate) = 4e3a1d7c48882ae861294fdaad9192b584ff7fa2f11946bb287104ced8d8c7e4b9c8103244b8e87349f13cf971ce83f3c99cb0344c2c7c5e573dc040962c5602
SHA512 (time-0.3.5.crate) = 751afd33abf9879b7bc524b50c63ca4722aa39d5bef3ddb371ec4d6efc9acbee9033c5813ec7d31e5e627e3c7fcd491ad4e7016130b7b09f931023e2bf395574

@ -1,19 +1,15 @@
--- time-0.2.26/Cargo.toml 1970-01-01T00:00:00+00:00
+++ time-0.2.26/Cargo.toml 2021-03-25T09:51:42.742432+00:00
@@ -64,15 +64,7 @@
default = ["deprecated", "std"]
deprecated = []
panicking-api = []
-std = ["libc", "winapi", "stdweb", "standback/std"]
-[target."cfg(target_arch = \"wasm32\")".dependencies.stdweb]
-version = "0.4.20"
-optional = true
-default-features = false
+std = ["libc", "standback/std"]
[target."cfg(unix)".dependencies.libc]
version = "0.2.89"
optional = true
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3.9"
-features = ["minwinbase", "minwindef", "timezoneapi"]
-optional = true
--- time-0.3.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.3.5/Cargo.toml 2021-11-18T12:34:37.939078+00:00
@@ -82,12 +82,5 @@
quickcheck = ["quickcheck-dep", "alloc"]
serde-human-readable = ["serde", "formatting", "parsing"]
std = ["alloc"]
-[target."cfg(__ui_tests)".dev-dependencies.trybuild]
-version = "=1.0.34"
[target."cfg(any(target_os = \"linux\", unsound_local_offset))".dependencies.libc]
version = "0.2.98"
-[target."cfg(bench)".dev-dependencies.criterion]
-version = "0.3.5"
-
-[target."cfg(bench)".dev-dependencies.criterion-cycles-per-byte]
-version = "0.1.2"

Loading…
Cancel
Save