Update to version 0.3.19; Fixes RHBZ#2137245

epel9
Fabio Valentini 2 years ago
parent fc47cb09c3
commit 49cbc72971
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -21,3 +21,5 @@
/time-0.3.13.crate /time-0.3.13.crate
/time-0.3.14.crate /time-0.3.14.crate
/time-0.3.15.crate /time-0.3.15.crate
/time-0.3.17.crate
/time-0.3.19.crate

@ -1,12 +1,11 @@
# Generated by rust2rpm 22 # Generated by rust2rpm 24
# * unit tests are excluded from published crates %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate time %global crate time
Name: rust-time Name: rust-time
Version: 0.3.15 Version: 0.3.19
Release: %autorelease Release: %autorelease
Summary: Date and time library Summary: Date and time library
@ -17,15 +16,14 @@ Source: %{crates_source}
Patch: time-fix-metadata-auto.diff Patch: time-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * remove WASM-specific features # * remove WASM-specific features
# * remove references to tests that are not included in published crates
Patch: time-fix-metadata.diff Patch: time-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: cargo-rpm-macros >= 24
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Date and time library. Fully interoperable with the standard library. Mostly Date and time library. Fully interoperable with the standard library.
compatible with #![no_std].} Mostly compatible with #![no_std].}
%description %{_description} %description %{_description}
@ -80,18 +78,6 @@ use the "formatting" feature of the "%{crate}" crate.
%files -n %{name}+formatting-devel %files -n %{name}+formatting-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+itoa-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+itoa-devel %{_description}
This package contains library source intended for building other packages which
use the "itoa" feature of the "%{crate}" crate.
%files -n %{name}+itoa-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+large-dates-devel %package -n %{name}+large-dates-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -152,18 +138,6 @@ use the "quickcheck" feature of the "%{crate}" crate.
%files -n %{name}+quickcheck-devel %files -n %{name}+quickcheck-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quickcheck-dep-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quickcheck-dep-devel %{_description}
This package contains library source intended for building other packages which
use the "quickcheck-dep" feature of the "%{crate}" crate.
%files -n %{name}+quickcheck-dep-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel %package -n %{name}+rand-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -224,18 +198,6 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-macros-devel %{_description}
This package contains library source intended for building other packages which
use the "time-macros" feature of the "%{crate}" crate.
%files -n %{name}+time-macros-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep

@ -1 +1 @@
SHA512 (time-0.3.15.crate) = 8783fe9cd6aa94cf6588ca1a734d0fa11c9e20e0d99b46b218db95bc185aee8a4324b2ece1a535b4378e87151f9837cd41f663c542f561019be99e3ed5f55325 SHA512 (time-0.3.19.crate) = 1ae3db13bd2734c026421a5373d645b2064556572c57160355b1e325106dbe7eb12ad7218b001c376999de63e3d8445451f3abd5fa3a03a9d7fe17e549038fef

@ -1,15 +1,15 @@
--- time-0.3.15/Cargo.toml 1970-01-01T00:00:01+00:00 --- time-0.3.19/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.3.15/Cargo.toml 1970-01-01T00:00:01+00:00 +++ time-0.3.19/Cargo.toml 2023-02-19T23:00:22.169586+00:00
@@ -132,18 +132,7 @@ @@ -144,18 +144,7 @@
"parsing", "parsing",
] ]
std = ["alloc"] std = ["alloc"]
-wasm-bindgen = ["js-sys"] -wasm-bindgen = ["dep:js-sys"]
- -
-[target."cfg(__ui_tests)".dev-dependencies.trybuild] -[target."cfg(__ui_tests)".dev-dependencies.trybuild]
-version = "1.0.63" -version = "1.0.68"
- -
-[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys] -[target."cfg(all(target_family = \"wasm\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys]
-version = "0.3.58" -version = "0.3.58"
-optional = true -optional = true
- -

@ -1,6 +1,22 @@
--- time-0.3.15/Cargo.toml 1970-01-01T00:00:01+00:00 --- time-0.3.19/Cargo.toml 1970-01-01T00:00:01+00:00
+++ time-0.3.15/Cargo.toml 2022-10-05T10:12:12.622820+00:00 +++ time-0.3.19/Cargo.toml 2023-02-19T23:01:02.904730+00:00
@@ -132,7 +132,6 @@ @@ -51,15 +51,6 @@
[lib]
bench = false
-
-[[test]]
-name = "tests"
-path = "../tests/main.rs"
-
-[[bench]]
-name = "benchmarks"
-path = "../benchmarks/main.rs"
-harness = false
[dependencies.itoa]
version = "1.0.1"
@@ -144,7 +135,6 @@
"parsing", "parsing",
] ]
std = ["alloc"] std = ["alloc"]

Loading…
Cancel
Save