Initial import (#2168973)
parent
2addf0aab3
commit
2d43bf1f24
@ -0,0 +1 @@
|
||||
/time-core-0.1.0.crate
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 24
|
||||
# * tests can only be run in-tree
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate time-core
|
||||
|
||||
Name: rust-time-core
|
||||
Version: 0.1.0
|
||||
Release: %autorelease
|
||||
Summary: Internal implementation details of the 'time' crate
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/time-core
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * improve crate description
|
||||
Patch: time-core-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Internal implementation details of the 'time' crate.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-Apache
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (time-core-0.1.0.crate) = f7e181a40a0052d7aedf78219a46f8876618342c710e819748a87a5bc0728e5b2fc7ba08e38ebfa6a17d6fb60382003bb35745ff1eabac1c8f8b47d186a383db
|
@ -0,0 +1,11 @@
|
||||
--- time-core-0.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ time-core-0.1.0/Cargo.toml 2023-02-19T23:04:20.088433+00:00
|
||||
@@ -18,7 +18,7 @@
|
||||
"Jacob Pratt <open-source@jhpratt.dev>",
|
||||
"Time contributors",
|
||||
]
|
||||
-description = "This crate is an implementation detail and should not be relied upon directly."
|
||||
+description = "Internal implementation details of the 'time' crate."
|
||||
keywords = [
|
||||
"date",
|
||||
"time",
|
Loading…
Reference in new issue