parent
08c168b9cf
commit
5efc641b52
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/tiff-0.6.1.crate
|
@ -0,0 +1,76 @@
|
|||||||
|
# Generated by rust2rpm 22
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate tiff
|
||||||
|
|
||||||
|
Name: rust-tiff0.6
|
||||||
|
Version: 0.6.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: TIFF decoding and encoding library in pure Rust
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/tiff
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||||
|
# * bump miniz_oxide from 0.4.1 to 0.5
|
||||||
|
Patch: tiff-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
TIFF decoding and encoding library in pure Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGES.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# * files for unit / integration tests are not included in published crates
|
||||||
|
%cargo_test -- --doc
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (tiff-0.6.1.crate) = ece5aaef610e0a7bcdea8c40571d497cd3ec79931e25129060b4f51cb40a28ef03fc131494bc841fa5b08eaa49a5acbc9332553cbc542019f1ec5eb5945d3538
|
@ -0,0 +1,14 @@
|
|||||||
|
--- tiff-0.6.1/Cargo.toml 2020-12-12T19:23:19+00:00
|
||||||
|
+++ tiff-0.6.1/Cargo.toml 2022-08-21T11:12:33.539697+00:00
|
||||||
|
@@ -29,10 +29,7 @@
|
||||||
|
package = "jpeg-decoder"
|
||||||
|
|
||||||
|
[dependencies.miniz_oxide]
|
||||||
|
-version = "0.4.1"
|
||||||
|
-features = ["no_extern_crate_alloc"]
|
||||||
|
+version = "0.5"
|
||||||
|
|
||||||
|
[dependencies.weezl]
|
||||||
|
version = "0.1.0"
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.3.1"
|
Loading…
Reference in new issue