Update to version 1.1.7; Fixes RHBZ#2168763

epel9 imports/e9/rust-thread_local-1.1.7-1.el9
Fabio Valentini 2 years ago
parent c906e3a771
commit b0e9b5300e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -5,3 +5,4 @@
/thread_local-1.1.0.crate /thread_local-1.1.0.crate
/thread_local-1.1.3.crate /thread_local-1.1.3.crate
/thread_local-1.1.4.crate /thread_local-1.1.4.crate
/thread_local-1.1.7.crate

@ -1,25 +1,22 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate thread_local %global crate thread_local
Name: rust-%{crate} Name: rust-thread_local
Version: 1.1.4 Version: 1.1.7
Release: %autorelease Release: %autorelease
Summary: Per-object thread-local storage Summary: Per-object thread-local storage
# Upstream license specification: Apache-2.0/MIT License: MIT OR Apache-2.0
License: ASL 2.0 or MIT
URL: https://crates.io/crates/thread_local URL: https://crates.io/crates/thread_local
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dependency to speed up builds # * drop unused, benchmark-only criterion dependency to speed up builds
Patch0: thread_local-fix-metadata.diff Patch: thread_local-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Per-object thread-local storage.} Per-object thread-local storage.}
@ -36,9 +33,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-APACHE LICENSE-MIT %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,7 +48,19 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (thread_local-1.1.4.crate) = db7ff3eb88a73d9313dd58d72397614c5aae6be1d64ead7f16535cae2857be3b27d189e7955308591ec64a0d67777fd2a62a2b124ca73facb9a2d8e0458bdbb5 SHA512 (thread_local-1.1.7.crate) = 3772452c2a349fb564d29bb06e13c8ae64807db27c3ee217fa04fd0e9847e94adeea582b82ffc2d9116f31ff478eb088550caf1346c263de49b55fa17b431c31

@ -1,17 +1,22 @@
--- thread_local-1.1.4/Cargo.toml 1970-01-01T00:00:01+00:00 --- thread_local-1.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
+++ thread_local-1.1.4/Cargo.toml 2022-01-24T16:20:07.354322+00:00 +++ thread_local-1.1.7/Cargo.toml 2023-02-19T21:27:42.639663+00:00
@@ -21,14 +21,6 @@ @@ -25,19 +25,12 @@
license = "Apache-2.0/MIT" license = "MIT OR Apache-2.0"
repository = "https://github.com/Amanieu/thread_local-rs" repository = "https://github.com/Amanieu/thread_local-rs"
-[[bench]] -[[bench]]
-name = "thread_local" -name = "thread_local"
-harness = false -harness = false
-required-features = ["criterion"]
-[dependencies.criterion]
-version = "0.3.3"
-optional = true
- -
[dependencies.cfg-if]
version = "1.0.0"
[dependencies.once_cell] [dependencies.once_cell]
version = "1.5.2" version = "1.5.2"
-[dev-dependencies.criterion]
-version = "0.4.0"
-
[features]
nightly = []

Loading…
Cancel
Save