commit
1b2ee7a3db
Binary file not shown.
@ -0,0 +1,22 @@
|
|||||||
|
--- thread_local-1.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ thread_local-1.1.7/Cargo.toml 2023-02-19T21:27:42.639663+00:00
|
||||||
|
@@ -25,19 +25,12 @@
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/Amanieu/thread_local-rs"
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "thread_local"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
[dependencies.cfg-if]
|
||||||
|
version = "1.0.0"
|
||||||
|
|
||||||
|
[dependencies.once_cell]
|
||||||
|
version = "1.5.2"
|
||||||
|
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.4.0"
|
||||||
|
-
|
||||||
|
[features]
|
||||||
|
nightly = []
|
||||||
|
|
@ -0,0 +1,192 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate thread_local
|
||||||
|
|
||||||
|
Name: rust-thread_local
|
||||||
|
Version: 1.1.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Per-object thread-local storage
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/thread_local
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dependency to speed up builds
|
||||||
|
Patch: thread_local-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Per-object thread-local storage.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+nightly-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+nightly-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "nightly" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+nightly-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.1.7-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sun Feb 19 2023 Fabio Valentini <decathorpe@gmail.com> - 1.1.7-1
|
||||||
|
- Update to version 1.1.7; Fixes RHBZ#2168763
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 25 2022 Fabio Valentini <decathorpe@gmail.com> - 1.1.4-1
|
||||||
|
- Update to version 1.1.4; Fixes RHBZ#2044117
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Nov 28 2021 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.1.3-4
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Feb 07 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.3-1
|
||||||
|
- Update to version 1.1.3.
|
||||||
|
- Fixes RHBZ#1919457
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 09 2021 Fabio Valentini <decathorpe@gmail.com> - 1.1.0-1
|
||||||
|
- Update to version 1.1.0.
|
||||||
|
- Fixes RHBZ#1913996
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-4
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 24 2020 Josh Stone <jistone@redhat.com> - 1.0.1-1
|
||||||
|
- Update to 1.0.1
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.6-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 20 11:12:52 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.6-6
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Sun Jun 09 11:02:42 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.6-5
|
||||||
|
- Regenerate
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.6-3
|
||||||
|
- Adapt to new packaging
|
||||||
|
|
||||||
|
* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.6-2
|
||||||
|
- Run tests in infrastructure
|
||||||
|
|
||||||
|
* Thu Aug 30 2018 Josh Stone <jistone@redhat.com> - 0.3.6-1
|
||||||
|
- Update to 0.3.6
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.5-2
|
||||||
|
- Rebuild for rust-packaging v5
|
||||||
|
|
||||||
|
* Mon Dec 11 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.5-1
|
||||||
|
- Update to 0.3.5
|
||||||
|
|
||||||
|
* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-2
|
||||||
|
- Bump lazy_static to 1
|
||||||
|
|
||||||
|
* Sat Jul 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.4-1
|
||||||
|
- Update to 0.3.4
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-4
|
||||||
|
- Bump unreachable dependency to 1.0
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-3
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.3-2
|
||||||
|
- Update to 0.3.3
|
||||||
|
|
||||||
|
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.2-2
|
||||||
|
- Use rich dependencies
|
||||||
|
|
||||||
|
* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.2-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue