Update to 3.3.0

epel9
Josh Stone 7 years ago
parent b06ed4a967
commit 9b131c6e1d

1
.gitignore vendored

@ -1 +1,2 @@
/thread-id-3.2.0.crate /thread-id-3.2.0.crate
/thread-id-3.3.0.crate

@ -5,8 +5,8 @@
%global crate thread-id %global crate thread-id
Name: rust-%{crate} Name: rust-%{crate}
Version: 3.2.0 Version: 3.3.0
Release: 3%{?dist} Release: 1%{?dist}
Summary: Get a unique thread ID Summary: Get a unique thread ID
License: MIT or ASL 2.0 License: MIT or ASL 2.0
@ -15,7 +15,7 @@ Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{
# Initial patched metadata # Initial patched metadata
# * No windows # * No windows
# * No redox # * No redox
Patch0: thread-id-3.2.0-fix-metadata.diff Patch0: thread-id-3.3.0-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -57,6 +57,9 @@ which use %{crate} from crates.io.
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version}/
%changelog %changelog
* Sat Mar 24 2018 Josh Stone <jistone@redhat.com> - 3.3.0-1
- Update to 3.3.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-3 * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1 +1 @@
SHA512 (thread-id-3.2.0.crate) = 251ebc0fb83a270b8fab9669ebbb7bc2cc44b1858fd298cb5f9ada0fc63ec6b46b44daf7d91c03f5ba646c14a2d6067c90988b59808e96f71e550b4cda290aa0 SHA512 (thread-id-3.3.0.crate) = 81ebde9b780de1f052dfb40af860c2877cc2f0a47bff2d4d58eda629b9c1874757c5bfd077277301bc3e068e3ac49eb5bab8ec660582f6778f16a47d4c6c3e1a

@ -1,10 +0,0 @@
--- thread-id-3.2.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ thread-id-3.2.0/Cargo.toml 2017-07-01T19:42:32.549811+02:00
@@ -22,7 +22,3 @@
repository = "https://github.com/ruuda/thread-id"
[target."cfg(unix)".dependencies.libc]
version = "0.2.6"
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
-version = "0.1"
-[target."cfg(windows)".dependencies.kernel32-sys]
-version = "0.2.1"

@ -0,0 +1,12 @@
--- thread-id-3.3.0/Cargo.toml 2018-03-23T05:49:40-07:00
+++ thread-id-3.3.0/Cargo.toml 2018-03-23T17:39:59.408637-07:00
@@ -15,9 +15,3 @@
[target.'cfg(unix)'.dependencies]
libc = "0.2.6"
-
-[target.'cfg(windows)'.dependencies]
-winapi = { version = "0.3", features = ["processthreadsapi"] }
-
-[target.'cfg(target_os = "redox")'.dependencies]
-redox_syscall = "0.1"
Loading…
Cancel
Save