Do not pull optional dependencies

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 8a0e0efe9c
commit d744fed485
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -7,20 +7,16 @@
Name: rust-%{crate}
Version: 0.10.0
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Small library for word wrapping, indenting, and dedenting strings
License: MIT
URL: https://crates.io/crates/textwrap
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * XXX: hyphenation is optional and brings a lot of legacy
Patch0: textwrap-fix-metadata.diff
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(term_size/default) >= 0.3.0 with crate(term_size/default) < 0.4.0)
BuildRequires: (crate(unicode-width/default) >= 0.1.3 with crate(unicode-width/default) < 0.2.0)
%if %{with check}
BuildRequires: (crate(lipsum/default) >= 0.5.0 with crate(lipsum/default) < 0.6.0)
@ -77,7 +73,7 @@ which use "term_size" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
@ -92,6 +88,9 @@ which use "term_size" feature of "%{crate}" crate.
%endif
%changelog
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.10.0-6
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1,13 +0,0 @@
--- textwrap-0.10.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ textwrap-0.10.0/Cargo.toml 2018-10-27T13:04:06.413156+02:00
@@ -24,10 +24,6 @@
repository = "https://github.com/mgeisler/textwrap"
[package.metadata.docs.rs]
all-features = true
-[dependencies.hyphenation]
-version = "0.6.1"
-optional = true
-
[dependencies.term_size]
version = "0.3.0"
optional = true
Loading…
Cancel
Save