parent
496a73fd2f
commit
48c92c99fb
@ -0,0 +1 @@
|
|||||||
|
/test-case-2.2.2.crate
|
@ -0,0 +1,101 @@
|
|||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate test-case
|
||||||
|
|
||||||
|
Name: rust-test-case2
|
||||||
|
Version: 2.2.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Procedural macro attribute for generating parametrized test cases
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/test-case
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop acceptance tests that are not included in published crates
|
||||||
|
# * exclude some files that are only useful for upstream development
|
||||||
|
# * relax version restrictions on dev-dependencies
|
||||||
|
Patch: test-case-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Provides #[test_case(...)] procedural macro attribute for generating
|
||||||
|
parametrized test cases easily.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+with-regex-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+with-regex-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "with-regex" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+with-regex-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
# integration tests rely on files that are not included in published crates
|
||||||
|
rm tests/acceptance_tests.rs
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,2 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Procedural macro attribute for generating parametrized test cases"
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (test-case-2.2.2.crate) = 505a417877f5e94e79ae14cce7ad003e1d10873d25fe71296110b6ad971a8f604cb5bea69109f0ddf641f7ca7ffb40203bb491b29d3d5e656c66f46dff470f41
|
@ -0,0 +1,56 @@
|
|||||||
|
--- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ test-case-2.2.2/Cargo.toml 2023-10-14T14:30:53.031377+00:00
|
||||||
|
@@ -18,7 +18,12 @@
|
||||||
|
"Wojciech Polak <frondeus@gmail.com>",
|
||||||
|
"Łukasz Biel <lukasz.p.biel@gmail.com>",
|
||||||
|
]
|
||||||
|
-exclude = ["tests/snapshots/**/*"]
|
||||||
|
+exclude = [
|
||||||
|
+ "/ci",
|
||||||
|
+ "/publish.sh",
|
||||||
|
+ "README.tpl",
|
||||||
|
+ "tests/snapshots/**/*",
|
||||||
|
+]
|
||||||
|
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
|
||||||
|
documentation = "https://docs.rs/test-case"
|
||||||
|
readme = "README.md"
|
||||||
|
@@ -40,10 +45,6 @@
|
||||||
|
path = "src/lib.rs"
|
||||||
|
doctest = false
|
||||||
|
|
||||||
|
-[[test]]
|
||||||
|
-name = "acceptance"
|
||||||
|
-path = "tests/acceptance_tests.rs"
|
||||||
|
-
|
||||||
|
[dependencies.regex]
|
||||||
|
version = "1.5"
|
||||||
|
optional = true
|
||||||
|
@@ -53,7 +54,7 @@
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dev-dependencies.indexmap]
|
||||||
|
-version = "=1.8.2"
|
||||||
|
+version = "1.8.2"
|
||||||
|
|
||||||
|
[dev-dependencies.insta]
|
||||||
|
version = "1.12"
|
||||||
|
@@ -62,16 +63,16 @@
|
||||||
|
version = "0.10"
|
||||||
|
|
||||||
|
[dev-dependencies.linked-hash-map]
|
||||||
|
-version = "=0.5.4"
|
||||||
|
+version = "0.5.4"
|
||||||
|
|
||||||
|
[dev-dependencies.once_cell]
|
||||||
|
-version = "=1.13.0"
|
||||||
|
+version = "1.13.0"
|
||||||
|
|
||||||
|
[dev-dependencies.regex]
|
||||||
|
version = "1.5"
|
||||||
|
|
||||||
|
[dev-dependencies.serde_yaml]
|
||||||
|
-version = "=0.8.25"
|
||||||
|
+version = "0.8.25"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
with-regex = [
|
Loading…
Reference in new issue