commit
45ce7df5f9
Binary file not shown.
@ -0,0 +1,56 @@
|
||||
--- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ test-case-2.2.2/Cargo.toml 2023-10-14T14:30:53.031377+00:00
|
||||
@@ -18,7 +18,12 @@
|
||||
"Wojciech Polak <frondeus@gmail.com>",
|
||||
"Łukasz Biel <lukasz.p.biel@gmail.com>",
|
||||
]
|
||||
-exclude = ["tests/snapshots/**/*"]
|
||||
+exclude = [
|
||||
+ "/ci",
|
||||
+ "/publish.sh",
|
||||
+ "README.tpl",
|
||||
+ "tests/snapshots/**/*",
|
||||
+]
|
||||
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
|
||||
documentation = "https://docs.rs/test-case"
|
||||
readme = "README.md"
|
||||
@@ -40,10 +45,6 @@
|
||||
path = "src/lib.rs"
|
||||
doctest = false
|
||||
|
||||
-[[test]]
|
||||
-name = "acceptance"
|
||||
-path = "tests/acceptance_tests.rs"
|
||||
-
|
||||
[dependencies.regex]
|
||||
version = "1.5"
|
||||
optional = true
|
||||
@@ -53,7 +54,7 @@
|
||||
default-features = false
|
||||
|
||||
[dev-dependencies.indexmap]
|
||||
-version = "=1.8.2"
|
||||
+version = "1.8.2"
|
||||
|
||||
[dev-dependencies.insta]
|
||||
version = "1.12"
|
||||
@@ -62,16 +63,16 @@
|
||||
version = "0.10"
|
||||
|
||||
[dev-dependencies.linked-hash-map]
|
||||
-version = "=0.5.4"
|
||||
+version = "0.5.4"
|
||||
|
||||
[dev-dependencies.once_cell]
|
||||
-version = "=1.13.0"
|
||||
+version = "1.13.0"
|
||||
|
||||
[dev-dependencies.regex]
|
||||
version = "1.5"
|
||||
|
||||
[dev-dependencies.serde_yaml]
|
||||
-version = "=0.8.25"
|
||||
+version = "0.8.25"
|
||||
|
||||
[features]
|
||||
with-regex = [
|
@ -0,0 +1,115 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate test-case
|
||||
|
||||
Name: rust-test-case2
|
||||
Version: 2.2.2
|
||||
Release: %autorelease
|
||||
Summary: Procedural macro attribute for generating parametrized test cases
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/test-case
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop acceptance tests that are not included in published crates
|
||||
# * exclude some files that are only useful for upstream development
|
||||
# * relax version restrictions on dev-dependencies
|
||||
Patch: test-case-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Provides #[test_case(...)] procedural macro attribute for generating
|
||||
parametrized test cases easily.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+regex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+regex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "regex" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+regex-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+with-regex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+with-regex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "with-regex" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+with-regex-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
# integration tests rely on files that are not included in published crates
|
||||
rm tests/acceptance_tests.rs
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.2.2-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Wed Oct 18 2023 Fabio Valentini <decathorpe@gmail.com> - 2.2.2-1
|
||||
- Initial import (test-case 2 compat package)
|
Loading…
Reference in new issue