Update to version 3.2.1; Fixes RHBZ#2057213

epel9
Fabio Valentini 1 year ago
parent a032262b9f
commit 8a3607452c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/test-case-1.2.0.crate /test-case-1.2.0.crate
/test-case-1.2.1.crate /test-case-1.2.1.crate
/test-case-2.2.2.crate /test-case-2.2.2.crate
/test-case-3.2.1.crate

@ -1,11 +1,11 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate test-case %global crate test-case
Name: rust-test-case Name: rust-test-case
Version: 2.2.2 Version: 3.2.1
Release: %autorelease Release: %autorelease
Summary: Procedural macro attribute for generating parametrized test cases Summary: Procedural macro attribute for generating parametrized test cases
@ -15,10 +15,9 @@ Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop acceptance tests that are not included in published crates # * drop acceptance tests that are not included in published crates
# * exclude some files that are only useful for upstream development # * exclude some files that are only useful for upstream development
# * relax version restrictions on dev-dependencies
Patch: test-case-fix-metadata.diff Patch: test-case-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Provides #[test_case(...)] procedural macro attribute for generating Provides #[test_case(...)] procedural macro attribute for generating
@ -78,7 +77,7 @@ use the "with-regex" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
# integration tests rely on files that are not included in published crates # integration tests rely on files that are not included in published crates
rm tests/acceptance_tests.rs rm tests/acceptance_tests.rs
%cargo_prep %cargo_prep

@ -0,0 +1,2 @@
[package]
summary = "Procedural macro attribute for generating parametrized test cases"

@ -1 +1 @@
SHA512 (test-case-2.2.2.crate) = 505a417877f5e94e79ae14cce7ad003e1d10873d25fe71296110b6ad971a8f604cb5bea69109f0ddf641f7ca7ffb40203bb491b29d3d5e656c66f46dff470f41 SHA512 (test-case-3.2.1.crate) = 60724384f47ed37089362c30eed7365de240c86fcd5dafe05061a29ce313fe9d91cc40a021455acc32fb4bbe7225aa81874f3e79c097fb41876e7d18cb4a2337

@ -1,56 +1,22 @@
--- test-case-2.2.2/Cargo.toml 1970-01-01T00:00:01+00:00 --- test-case-3.2.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ test-case-2.2.2/Cargo.toml 2023-02-27T17:04:11.944205+00:00 +++ test-case-3.2.1/Cargo.toml 2023-10-08T21:28:31.154495+00:00
@@ -18,7 +18,12 @@ @@ -19,7 +19,7 @@
"Wojciech Polak <frondeus@gmail.com>", "Wojciech Polak <frondeus@gmail.com>",
"Łukasz Biel <lukasz.p.biel@gmail.com>", "Łukasz Biel <lukasz.p.biel@gmail.com>",
] ]
-exclude = ["tests/snapshots/**/*"] -exclude = ["tests/snapshots/**/*"]
+exclude = [ +exclude = ["tests/snapshots/**/*", "/scripts", "README.tpl"]
+ "/ci",
+ "/publish.sh",
+ "README.tpl",
+ "tests/snapshots/**/*",
+]
description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily" description = "Provides #[test_case(...)] procedural macro attribute for generating parametrized test cases easily"
documentation = "https://docs.rs/test-case" documentation = "https://docs.rs/test-case"
readme = "README.md" readme = "README.md"
@@ -40,10 +45,6 @@ @@ -40,10 +40,6 @@
[lib]
path = "src/lib.rs" path = "src/lib.rs"
doctest = false doctest = false
-
-[[test]] -[[test]]
-name = "acceptance" -name = "acceptance"
-path = "tests/acceptance_tests.rs" -path = "tests/acceptance_tests.rs"
-
[dependencies.regex]
version = "1.5"
optional = true
@@ -53,7 +54,7 @@
default-features = false
[dev-dependencies.indexmap]
-version = "=1.8.2"
+version = "1.8.2"
[dev-dependencies.insta] [dependencies.regex]
version = "1.12"
@@ -62,16 +63,16 @@
version = "0.10"
[dev-dependencies.linked-hash-map]
-version = "=0.5.4"
+version = "0.5.4"
[dev-dependencies.once_cell]
-version = "=1.13.0"
+version = "1.13.0"
[dev-dependencies.regex]
version = "1.5" version = "1.5"
[dev-dependencies.serde_yaml]
-version = "=0.8.25"
+version = "0.8.25"
[features]
with-regex = [

Loading…
Cancel
Save