parent
e5fdeee1b1
commit
695a966179
@ -0,0 +1 @@
|
|||||||
|
/test-assembler-0.1.5.crate
|
@ -0,0 +1,60 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate test-assembler
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.5
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Set of types for building complex binary streams
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/test-assembler
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Bump byteorder to 1, https://github.com/luser/rust-test-assembler/pull/7
|
||||||
|
Patch0: test-assembler-0.1.5-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A set of types for building complex binary streams.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 03 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.5-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (test-assembler-0.1.5.crate) = 7982da4fce56e50c75c163943454d2f6cb4438a2357c55baf2cf574ad7bdb5c4fb5f9be51a84ecdbfb3045ffc9be5318ba1ffb1e1a13dc8318851b335b0b235f
|
@ -0,0 +1,8 @@
|
|||||||
|
--- test-assembler-0.1.5/Cargo.toml 2016-09-12T23:02:38+02:00
|
||||||
|
+++ test-assembler-0.1.5/Cargo.toml 2017-12-03T21:06:49.517005+01:00
|
||||||
|
@@ -12,4 +12,4 @@
|
||||||
|
]
|
||||||
|
|
||||||
|
[dependencies]
|
||||||
|
-byteorder = "0.5.0"
|
||||||
|
+byteorder = "1"
|
Loading…
Reference in new issue