parent
0fea6dae12
commit
540bd8f4b3
@ -0,0 +1 @@
|
||||
/termion-1.5.1.crate
|
@ -0,0 +1,61 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate termion
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Bindless library for manipulating terminals
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/termion
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No redox
|
||||
Patch0: termion-1.5.1-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.8 with crate(libc) < 0.3.0)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
A bindless library for manipulating terminals.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/logo.svg
|
||||
|
||||
%changelog
|
||||
* Sun Nov 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.5.1-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (termion-1.5.1.crate) = 1d1536f08600c7c1f414b4579a1a6e7eff91f4c105504125118d3cadf71c7886a352d1c5f7e07f3d7c28aa8b4752f07b51eddb4d9adc6a9286f7b6bade2bec76
|
@ -0,0 +1,10 @@
|
||||
--- termion-1.5.1/Cargo.toml 2017-08-04T00:12:31+02:00
|
||||
+++ termion-1.5.1/Cargo.toml 2017-11-19T10:22:50.337549+01:00
|
||||
@@ -11,7 +11,3 @@
|
||||
|
||||
[target.'cfg(not(target_os = "redox"))'.dependencies]
|
||||
libc = "0.2.8"
|
||||
-
|
||||
-[target.'cfg(target_os = "redox")'.dependencies]
|
||||
-redox_syscall = "0.1"
|
||||
-redox_termios = "0.1"
|
Loading…
Reference in new issue