epel10
imports/epel10/rust-terminal_size0.3-0.3.0-1.el10
parent
23ca330cfc
commit
5355604047
@ -0,0 +1 @@
|
||||
/terminal_size-0.3.0.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-terminal_size0.3
|
||||
|
||||
The rust-terminal_size0.3 package
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate terminal_size
|
||||
|
||||
Name: rust-terminal_size0.3
|
||||
Version: 0.3.0
|
||||
Release: %autorelease
|
||||
Summary: Gets the size of your Linux or Windows terminal
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/terminal_size
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: terminal_size-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Gets the size of your Linux or Windows terminal.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# skip tests that don't work without a TTY
|
||||
%cargo_test -- -- --skip unix::compare_with_stty
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (terminal_size-0.3.0.crate) = f3bc9144aa8a87556543584a2495df6267ce3bb017f3ed3d00fa43e89b5de783e1285ca62dbad9dd9c3b37e3a476a6f3ab0804eba2411cb594a569bbdb310681
|
@ -0,0 +1,12 @@
|
||||
--- terminal_size-0.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ terminal_size-0.3.0/Cargo.toml 2024-10-04T20:12:12.140854+00:00
|
||||
@@ -31,9 +31,3 @@
|
||||
version = "0.38.0"
|
||||
features = ["termios"]
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.48.0"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Console",
|
||||
-]
|
Loading…
Reference in new issue