epel9
imports/e9/rust-terminal_size0.2-0.2.6-1.el9
parent
69189e00a3
commit
1a7159998d
@ -0,0 +1 @@
|
||||
/terminal_size-0.2.6.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-terminal_size0.2
|
||||
|
||||
The rust-terminal_size0.2 package
|
@ -0,0 +1,72 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate terminal_size
|
||||
|
||||
Name: rust-terminal_size0.2
|
||||
Version: 0.2.6
|
||||
Release: %autorelease
|
||||
Summary: Gets the size of your Linux or Windows terminal
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/terminal_size
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip foreign dependencies
|
||||
Patch: terminal_size-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Gets the size of your Linux or Windows terminal.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
# skip tests that don't work without a TTY
|
||||
%cargo_test -- -- --skip unix::compare_with_stty
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1 @@
|
||||
SHA512 (terminal_size-0.2.6.crate) = 95f38bc00f8c5e1a6913bb2a0a7c46d96e02a4f3234af1623ad3d7be41eae677e77f1b5d5d005d1e9d778fcc6c87196f67a51ab37caab5b4d299da79c85d06ed
|
@ -0,0 +1,12 @@
|
||||
--- terminal_size-0.2.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ terminal_size-0.2.6/Cargo.toml 2023-09-20T09:58:34.443659+00:00
|
||||
@@ -31,9 +31,3 @@
|
||||
version = "0.37.0"
|
||||
features = ["termios"]
|
||||
|
||||
-[target."cfg(windows)".dependencies.windows-sys]
|
||||
-version = "0.48.0"
|
||||
-features = [
|
||||
- "Win32_Foundation",
|
||||
- "Win32_System_Console",
|
||||
-]
|
Loading…
Reference in new issue