parent
5a0c2bd8c7
commit
377b33ce21
@ -0,0 +1 @@
|
||||
/terminal_size-0.1.8.crate
|
@ -0,0 +1,74 @@
|
||||
# Generated by rust2rpm
|
||||
# ENOTTY: stty: /dev/stderr: Inappropriate ioctl for device
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate terminal_size
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Gets the size of your Linux or Windows terminal
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/terminal_size
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# - Remove Windows-only dependencies
|
||||
Patch0: terminal_size-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
BuildRequires: (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
|
||||
|
||||
%global _description \
|
||||
Gets the size of your Linux or Windows terminal.
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 25 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.8-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (terminal_size-0.1.8.crate) = 2392e2d3c34e6dc83c43e804ceb9990af82066879a2d74b21e4ab88bf9a8698f34c8734f3e8e3febdda44c0633819809259fb34bd48d138d22ad6c4b448f396c
|
@ -0,0 +1,9 @@
|
||||
--- terminal_size-0.1.8/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ terminal_size-0.1.8/Cargo.toml 2019-04-25T15:14:42.757257+02:00
|
||||
@@ -21,6 +21,3 @@
|
||||
repository = "https://github.com/eminence/terminal-size"
|
||||
[dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["winnt", "processenv", "wincon", "winbase"]
|
@ -0,0 +1 @@
|
||||
1
|
@ -0,0 +1,5 @@
|
||||
---
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
# `cargo test` usually eats more than 1G.
|
||||
m: 4G
|
@ -0,0 +1,13 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
repositories:
|
||||
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||
dest: rust
|
||||
tests:
|
||||
- rust/cargo-test
|
||||
environment:
|
||||
pkg: rust-terminal_size
|
Loading…
Reference in new issue