Refresh packaging (incl. using SDPX license expression)

epel9
Zbigniew Jędrzejewski-Szmek 3 years ago
parent 16f24bab60
commit 969cd349c1

@ -1,4 +1,4 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 21
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
@ -10,19 +10,15 @@ Release: %autorelease
Summary: Functions for determining terminal sizes and dimensions Summary: Functions for determining terminal sizes and dimensions
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/term_size URL: https://crates.io/crates/term_size
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * No windows Patch: term_size-fix-metadata.diff
Patch0: term_size-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Functions for determining terminal sizes and dimensions.} Functions for determining terminal sizes and dimensions.}
@ -35,13 +31,16 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md CHANGELOG.md CONTRIBUTORS.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTORS.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,11 +48,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debug-devel %package -n %{name}+debug-devel
Summary: %{summary} Summary: %{summary}
@ -61,11 +60,11 @@ BuildArch: noarch
%description -n %{name}+debug-devel %{_description} %description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "debug" feature of "%{crate}" crate. use the "debug" feature of the "%{crate}" crate.
%files -n %{name}+debug-devel %files -n %{name}+debug-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel %package -n %{name}+nightly-devel
Summary: %{summary} Summary: %{summary}
@ -73,11 +72,11 @@ BuildArch: noarch
%description -n %{name}+nightly-devel %{_description} %description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "nightly" feature of "%{crate}" crate. use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel %files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+travis-devel %package -n %{name}+travis-devel
Summary: %{summary} Summary: %{summary}
@ -85,11 +84,11 @@ BuildArch: noarch
%description -n %{name}+travis-devel %{_description} %description -n %{name}+travis-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "travis" feature of "%{crate}" crate. use the "travis" feature of the "%{crate}" crate.
%files -n %{name}+travis-devel %files -n %{name}+travis-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-devel %package -n %{name}+unstable-devel
Summary: %{summary} Summary: %{summary}
@ -97,11 +96,11 @@ BuildArch: noarch
%description -n %{name}+unstable-devel %{_description} %description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "unstable" feature of "%{crate}" crate. use the "unstable" feature of the "%{crate}" crate.
%files -n %{name}+unstable-devel %files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1,5 +1,5 @@
--- term_size-0.3.2/Cargo.toml 2020-05-02T02:35:26+00:00 --- term_size-0.3.2/Cargo.toml 2020-05-02T02:35:26+00:00
+++ term_size-0.3.2/Cargo.toml 2020-05-05T01:35:29.061086+00:00 +++ term_size-0.3.2/Cargo.toml 2022-07-05T13:41:05.452374+00:00
@@ -62,9 +62,6 @@ @@ -62,9 +62,6 @@
unstable = [] unstable = []
[target."cfg(not(target_os = \"windows\"))".dependencies.libc] [target."cfg(not(target_os = \"windows\"))".dependencies.libc]

Loading…
Cancel
Save