parent
5f4e7b3efa
commit
9ab3f9b8b0
@ -1,2 +1,3 @@
|
|||||||
/term-0.4.6.crate
|
/term-0.4.6.crate
|
||||||
/term-0.5.1.crate
|
/term-0.5.1.crate
|
||||||
|
/term-0.5.2.crate
|
||||||
|
@ -1,60 +0,0 @@
|
|||||||
From 84cfdb51775b327fedf21784749d862fdffa10b4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Steven Allen <steven@stebalien.com>
|
|
||||||
Date: Fri, 27 Jul 2018 16:30:29 -0700
|
|
||||||
Subject: [PATCH] fix warning due to use of env::home_dir
|
|
||||||
|
|
||||||
---
|
|
||||||
src/lib.rs | 10 +++++++---
|
|
||||||
src/terminfo/searcher.rs | 4 +++-
|
|
||||||
2 files changed, 10 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/lib.rs b/src/lib.rs
|
|
||||||
index d8c1e7a64210..f28699d77d52 100644
|
|
||||||
--- a/src/lib.rs
|
|
||||||
+++ b/src/lib.rs
|
|
||||||
@@ -56,13 +56,17 @@
|
|
||||||
//! [win]: http://msdn.microsoft.com/en-us/library/windows/desktop/ms682010%28v=vs.85%29.aspx
|
|
||||||
//! [ti]: https://en.wikipedia.org/wiki/Terminfo
|
|
||||||
|
|
||||||
-#![doc(html_logo_url = "https://www.rust-lang.org/logos/rust-logo-128x128-blk-v2.png",
|
|
||||||
- html_favicon_url = "https://doc.rust-lang.org/favicon.ico",
|
|
||||||
- html_root_url = "https://stebalien.github.io/doc/term/term/", test(attr(deny(warnings))))]
|
|
||||||
+#![doc(
|
|
||||||
+ html_logo_url = "https://www.rust-lang.org/logos/rust-logo-128x128-blk-v2.png",
|
|
||||||
+ html_favicon_url = "https://doc.rust-lang.org/favicon.ico",
|
|
||||||
+ html_root_url = "https://stebalien.github.io/doc/term/term/",
|
|
||||||
+ test(attr(deny(warnings)))
|
|
||||||
+)]
|
|
||||||
#![deny(missing_docs)]
|
|
||||||
#![cfg_attr(test, deny(warnings))]
|
|
||||||
|
|
||||||
extern crate byteorder;
|
|
||||||
+extern crate dirs;
|
|
||||||
|
|
||||||
use std::io::prelude::*;
|
|
||||||
|
|
||||||
diff --git a/src/terminfo/searcher.rs b/src/terminfo/searcher.rs
|
|
||||||
index 76865748db6d..27eabaa38648 100644
|
|
||||||
--- a/src/terminfo/searcher.rs
|
|
||||||
+++ b/src/terminfo/searcher.rs
|
|
||||||
@@ -16,6 +16,8 @@ use std::env;
|
|
||||||
use std::fs;
|
|
||||||
use std::path::PathBuf;
|
|
||||||
|
|
||||||
+use dirs;
|
|
||||||
+
|
|
||||||
/// Return path to database entry for `term`
|
|
||||||
pub fn get_dbpath_for_term(term: &str) -> Option<PathBuf> {
|
|
||||||
let mut dirs_to_search = Vec::new();
|
|
||||||
@@ -56,7 +58,7 @@ pub fn get_dbpath_for_term(term: &str) -> Option<PathBuf> {
|
|
||||||
// ~/.terminfo, ncurses will search /etc/terminfo, then
|
|
||||||
// /lib/terminfo, and eventually /usr/share/terminfo.
|
|
||||||
// On Haiku the database can be found at /boot/system/data/terminfo
|
|
||||||
- if let Some(mut homedir) = env::home_dir() {
|
|
||||||
+ if let Some(mut homedir) = dirs::home_dir() {
|
|
||||||
homedir.push(".terminfo");
|
|
||||||
dirs_to_search.push(homedir)
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (term-0.5.1.crate) = cbfe1f3653a31f07a8bdc0b46a5093f45e38b587b639b8683d361480937d65c531abab7c3af3ec2cc8aa3ac41cc3ccd93e31868fd7b327152e878a10070733b0
|
SHA512 (term-0.5.2.crate) = 421b04f067f66ddecb615d715c828c98d3fa351b3490ec76bfa02bf430039717da5a168c20033399d5544ded5aed35c2aa4c9e6ea5018211bfe615389d18f3d6
|
||||||
|
@ -1,21 +1,12 @@
|
|||||||
--- term-0.5.1/Cargo.toml 1970-01-01T01:00:00+01:00
|
--- term-0.5.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
+++ term-0.5.1/Cargo.toml 2018-11-10T12:51:35.496690+01:00
|
+++ term-0.5.2/Cargo.toml 2019-03-28T22:33:27.623495+00:00
|
||||||
@@ -21,14 +21,15 @@
|
@@ -30,9 +30,6 @@
|
||||||
categories = ["command-line-interface"]
|
|
||||||
license = "MIT/Apache-2.0"
|
|
||||||
repository = "https://github.com/Stebalien/term"
|
|
||||||
+exclude = ["/scripts/*", "/.travis.yml", "/appveyor.yml"]
|
|
||||||
[dependencies.byteorder]
|
|
||||||
version = "1.2.1"
|
|
||||||
|
|
||||||
+[dependencies.dirs]
|
|
||||||
+version = "1.0.2"
|
|
||||||
+
|
|
||||||
[features]
|
[features]
|
||||||
default = []
|
default = []
|
||||||
-[target."cfg(windows)".dependencies.winapi]
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
-version = "0.3"
|
-version = "0.3"
|
||||||
-features = ["wincon", "handleapi", "fileapi"]
|
-features = ["consoleapi", "wincon", "handleapi", "fileapi"]
|
||||||
[badges.appveyor]
|
[badges.appveyor]
|
||||||
repository = "Stebalien/term"
|
repository = "Stebalien/term"
|
||||||
|
|
||||||
|
Loading…
Reference in new issue