parent
ffafc848fc
commit
58490a5a70
@ -1 +1,2 @@
|
|||||||
/tar-0.4.14.crate
|
/tar-0.4.14.crate
|
||||||
|
/tar-0.4.15.crate
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
From 2fdfdff070920cfc087e3dfb1624c199d1daab84 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
Date: Sat, 13 Jan 2018 19:01:15 +0100
|
|
||||||
Subject: [PATCH] deps: Update xattr to 0.2
|
|
||||||
|
|
||||||
get() used to return Result<Vec<u8>> which was indicating problem
|
|
||||||
either with getting attributes or those attributes being empty.
|
|
||||||
Now it returns Result<Option<Vec<u8>>> where Result is for reporting
|
|
||||||
problems with getting attrs and Option for showing whether attrs are
|
|
||||||
empty.
|
|
||||||
|
|
||||||
Then make sure that no_xattrs test is really trying to test something.
|
|
||||||
|
|
||||||
And also make indent to be consistent.
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
|
|
||||||
---
|
|
||||||
tests/all.rs | 14 ++++++++------
|
|
||||||
1 file changed, 8 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/all.rs b/tests/all.rs
|
|
||||||
index 6ecd440..1977362 100644
|
|
||||||
--- a/tests/all.rs
|
|
||||||
+++ b/tests/all.rs
|
|
||||||
@@ -201,19 +201,21 @@ fn xattrs() {
|
|
||||||
t!(ar.unpack(td.path()));
|
|
||||||
|
|
||||||
let val = xattr::get(td.path().join("a/b"), "user.pax.flags").unwrap();
|
|
||||||
- assert_eq!(val, "epm".as_bytes());
|
|
||||||
+ assert_eq!(val.unwrap(), "epm".as_bytes());
|
|
||||||
}
|
|
||||||
|
|
||||||
#[test]
|
|
||||||
#[cfg(all(unix, feature = "xattr"))]
|
|
||||||
fn no_xattrs() {
|
|
||||||
- let td = t!(TempDir::new("tar-rs"));
|
|
||||||
- let rdr = Cursor::new(tar!("xattrs.tar"));
|
|
||||||
- let mut ar = Archive::new(rdr);
|
|
||||||
+ // If /tmp is a tmpfs, xattr will fail
|
|
||||||
+ // The xattr crate's unit tests also use /var/tmp for this reason
|
|
||||||
+ let td = t!(TempDir::new_in("/var/tmp", "tar-rs"));
|
|
||||||
+ let rdr = Cursor::new(tar!("xattrs.tar"));
|
|
||||||
+ let mut ar = Archive::new(rdr);
|
|
||||||
ar.set_unpack_xattrs(false);
|
|
||||||
- t!(ar.unpack(td.path()));
|
|
||||||
+ t!(ar.unpack(td.path()));
|
|
||||||
|
|
||||||
- xattr::get(td.path().join("a/b"), "user.pax.flags").unwrap_err();
|
|
||||||
+ assert_eq!(xattr::get(td.path().join("a/b"), "user.pax.flags").unwrap(), None);
|
|
||||||
}
|
|
||||||
|
|
||||||
#[test]
|
|
||||||
--
|
|
||||||
2.15.1
|
|
||||||
|
|
@ -1 +1 @@
|
|||||||
SHA512 (tar-0.4.14.crate) = b46685caadf335ec296a6d7ff5c2bae31a50395a3681a733998dbdf6295a4a55e7b094340b4679f9468f430f5c92734e08b75123de935dc5636b36d06c498b96
|
SHA512 (tar-0.4.15.crate) = b5e95534836e99ef749dc4d517e60f799ca6a88a246b30b7bf9731afa3fe5f207ad14ecd11435da43f7d634ca16bd3766dfb94fe7ee0cbb1611773aecc46b060
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
--- tar-0.4.14/Cargo.toml 1970-01-01T01:00:00+01:00
|
|
||||||
+++ tar-0.4.14/Cargo.toml 2018-01-13T18:37:52.043131+01:00
|
|
||||||
@@ -28,11 +28,9 @@
|
|
||||||
|
|
||||||
[features]
|
|
||||||
default = ["xattr"]
|
|
||||||
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
|
||||||
-version = "0.1"
|
|
||||||
[target."cfg(unix)".dependencies.libc]
|
|
||||||
version = "0.2"
|
|
||||||
|
|
||||||
[target."cfg(unix)".dependencies.xattr]
|
|
||||||
-version = "0.1.7"
|
|
||||||
+version = "0.2"
|
|
||||||
optional = true
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- tar-0.4.15/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ tar-0.4.15/Cargo.toml 2018-04-25T13:31:34.104704+02:00
|
||||||
|
@@ -28,8 +28,6 @@
|
||||||
|
|
||||||
|
[features]
|
||||||
|
default = ["xattr"]
|
||||||
|
-[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
|
||||||
|
-version = "0.1"
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
|
Loading…
Reference in new issue