parent
d741e6d9ea
commit
8e97deac3c
@ -0,0 +1 @@
|
||||
/tabwriter-1.0.3.crate
|
@ -0,0 +1,68 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate tabwriter
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.0.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Elastic tabstops
|
||||
|
||||
License: Unlicense or MIT
|
||||
URL: https://crates.io/crates/tabwriter
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Bump lazy_static to 1,
|
||||
# * Bump ansi_term to 0.10,
|
||||
Patch0: tabwriter-1.0.3-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
|
||||
BuildRequires: (crate(regex) >= 0.2.1 with crate(regex) < 0.3.0)
|
||||
BuildRequires: (crate(unicode-width) >= 0.1.0 with crate(unicode-width) < 0.2.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(ansi_term) >= 0.10.0 with crate(ansi_term) < 0.11.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Elastic tabstops.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license COPYING LICENSE-MIT UNLICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,session.vim}
|
||||
|
||||
%changelog
|
||||
* Sat Jan 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.3-1
|
||||
- Initial package
|
@ -0,0 +1 @@
|
||||
SHA512 (tabwriter-1.0.3.crate) = 23ed8b9e4273177c6225dc76a20723b4ca114244262b4588b3c30d6901f8287e2047d1e17668c4a16db1b71ac4c856232e8d72898ca299fa3b521a19837bfe1b
|
@ -0,0 +1,15 @@
|
||||
--- tabwriter-1.0.3/Cargo.toml 2017-01-03T23:46:06+01:00
|
||||
+++ tabwriter-1.0.3/Cargo.toml 2018-01-27T13:12:51.895617+01:00
|
||||
@@ -13,10 +13,10 @@
|
||||
[dependencies]
|
||||
unicode-width = "0.1"
|
||||
regex = { version = "^0.2.1", optional = true }
|
||||
-lazy_static = { version = "0.2", optional = true}
|
||||
+lazy_static = { version = "1", optional = true}
|
||||
|
||||
[dev-dependencies]
|
||||
-ansi_term = "0.7"
|
||||
+ansi_term = "0.10"
|
||||
|
||||
[features]
|
||||
default = []
|
Loading…
Reference in new issue