Update to version 0.28.2; Fixes RHBZ#2173415

epel9
Fabio Valentini 2 years ago
parent fa97f9ae68
commit eb8dfb49cc
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -29,3 +29,4 @@
/sysinfo-0.24.7.crate /sysinfo-0.24.7.crate
/sysinfo-0.27.7.crate /sysinfo-0.27.7.crate
/sysinfo-0.28.0.crate /sysinfo-0.28.0.crate
/sysinfo-0.28.2.crate

@ -1,3 +0,0 @@
# rust-sysinfo
The rust-sysinfo package

@ -5,7 +5,7 @@
%global crate sysinfo %global crate sysinfo
Name: rust-sysinfo Name: rust-sysinfo
Version: 0.28.0 Version: 0.28.2
Release: %autorelease Release: %autorelease
Summary: Library to get system information such as processes, CPUs, disks, components and networks Summary: Library to get system information such as processes, CPUs, disks, components and networks
@ -129,23 +129,8 @@ use the "serde" feature of the "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
# skip tests that fail when run on vms, on tmpfs, or in systemd-nspawn # * skip tests that fail in VMs or in systemd-nspawn containers on different architectures
%if 0%{?fedora} >= 38 %cargo_test -- -- --skip test::check_all_process_uids_resolvable --skip test::check_cpu_usage --skip test::check_cpus_number --skip test::check_processes_cpu_usage --skip test_disks
SKIP_TESTS=""
%else
SKIP_TESTS=" --skip test::check_all_process_uids_resolvable --skip test_disks"
%endif
%ifarch s390x
# these tests panic with assertion failures on s390x
SKIP_TESTS+=" --skip test::check_cpus_number --skip test::check_processes_cpu_usage"
%endif
if [ -e ${SKIP_TESTS} ]; then
%cargo_test
else
%cargo_test -- -- ${SKIP_TESTS}
fi
%endif %endif
%changelog %changelog

@ -1 +1 @@
SHA512 (sysinfo-0.28.0.crate) = 85687f7809d52209e38aa53432125b29dd193c13a48439204ff747564dce12bab1675c5f148b5001b0a5d9f30e91ec93265dd905248bd361e4340228a3fc6de5 SHA512 (sysinfo-0.28.2.crate) = d94194995ed363bf2444c0f68865b5862e3132f0d4093be1b431f37411cfa1402504bdbc7a14150b49055fa15cf75fd4680d1b6535cfd41ca587a8d6492df90a

@ -1,5 +1,5 @@
--- sysinfo-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sysinfo-0.28.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sysinfo-0.28.0/Cargo.toml 2023-02-22T18:42:41.367029+00:00 +++ sysinfo-0.28.2/Cargo.toml 2023-03-16T20:26:51.008672+00:00
@@ -58,52 +58,9 @@ @@ -58,52 +58,9 @@
[target."cfg(all(target_os = \"linux\", not(target_os = \"android\")))".dev-dependencies.tempfile] [target."cfg(all(target_os = \"linux\", not(target_os = \"android\")))".dev-dependencies.tempfile]
version = "3.2" version = "3.2"

@ -1,5 +1,5 @@
--- sysinfo-0.28.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sysinfo-0.28.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sysinfo-0.28.0/Cargo.toml 2023-02-22T18:43:20.922551+00:00 +++ sysinfo-0.28.2/Cargo.toml 2023-03-16T20:27:08.509739+00:00
@@ -47,13 +47,10 @@ @@ -47,13 +47,10 @@
version = "1.0" version = "1.0"

Loading…
Cancel
Save