Initial import (#1776089).
parent
42334cb13b
commit
6af945ddd6
@ -0,0 +1 @@
|
|||||||
|
/sysinfo-0.10.2.crate
|
@ -0,0 +1,106 @@
|
|||||||
|
# Generated by rust2rpm 10
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate sysinfo
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.10.2
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Library to handle processes
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/sysinfo
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Remove Windows only dependencies
|
||||||
|
Patch0: sysinfo-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A system handler to get information and interact with processes written in
|
||||||
|
Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+c-interface-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+c-interface-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "c-interface" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+c-interface-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+debug-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+debug-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "debug" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+debug-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Dec 12 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 0.10.2-1
|
||||||
|
- Update to 0.10.2
|
||||||
|
|
||||||
|
* Mon Nov 25 07:57:54 EET 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 0.9.6-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (sysinfo-0.10.2.crate) = 907907568ae3a497b448b67ef9f6687fa702fc8117287487dc185cb2450277e38063b95a8f93b5510c02b660e09b373e634f5fe030663d1eea01dff45414db0b
|
@ -0,0 +1,15 @@
|
|||||||
|
--- sysinfo-0.10.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ sysinfo-0.10.2/Cargo.toml 2019-12-12T14:01:32.636646+00:00
|
||||||
|
@@ -39,12 +39,7 @@
|
||||||
|
debug = ["libc/extra_traits"]
|
||||||
|
[target."cfg(not(target_os = \"unknown\"))".dependencies.libc]
|
||||||
|
version = "0.2"
|
||||||
|
-[target."cfg(windows)".dependencies.ntapi]
|
||||||
|
-version = "0.3"
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["fileapi", "handleapi", "ioapiset", "minwindef", "pdh", "psapi", "synchapi", "sysinfoapi", "winbase", "winerror", "winioctl", "winnt", "oleauto", "wbemcli", "rpcdce", "combaseapi", "objidl", "objbase"]
|
||||||
|
[badges.appveyor]
|
||||||
|
repository = "GuillaumeGomez/sysinfo"
|
||||||
|
service = "github"
|
Loading…
Reference in new issue