commit
e225467383
Binary file not shown.
@ -0,0 +1,34 @@
|
|||||||
|
--- sys-locale-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ sys-locale-0.3.1/Cargo.toml 2023-08-28T16:04:54.741904+00:00
|
||||||
|
@@ -27,31 +27,5 @@
|
||||||
|
|
||||||
|
[features]
|
||||||
|
js = [
|
||||||
|
- "js-sys",
|
||||||
|
- "wasm-bindgen",
|
||||||
|
- "web-sys",
|
||||||
|
]
|
||||||
|
|
||||||
|
-[target."cfg(all(target_family = \"wasm\", not(unix)))".dependencies.js-sys]
|
||||||
|
-version = "0.3"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[target."cfg(all(target_family = \"wasm\", not(unix)))".dependencies.wasm-bindgen]
|
||||||
|
-version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[target."cfg(all(target_family = \"wasm\", not(unix)))".dependencies.web-sys]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = [
|
||||||
|
- "Window",
|
||||||
|
- "WorkerGlobalScope",
|
||||||
|
- "Navigator",
|
||||||
|
- "WorkerNavigator",
|
||||||
|
-]
|
||||||
|
-optional = true
|
||||||
|
-
|
||||||
|
-[target."cfg(all(target_family = \"wasm\", not(unix)))".dev-dependencies.wasm-bindgen-test]
|
||||||
|
-version = "0.3"
|
||||||
|
-
|
||||||
|
-[target."cfg(target_os = \"android\")".dependencies.libc]
|
||||||
|
-version = "0.2"
|
@ -0,0 +1,113 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate sys-locale
|
||||||
|
|
||||||
|
Name: rust-sys-locale
|
||||||
|
Version: 0.3.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Small and lightweight library to obtain the active system locale
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/sys-locale
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: sys-locale-fix-metadata-auto.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Small and lightweight library to obtain the active system locale.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.1-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Mon Aug 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
|
||||||
|
- Update to version 0.3.1; Fixes RHBZ#2235205
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 23 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.3.0-2
|
||||||
|
- Errata: new version is 0.3.0 not 0.80.0
|
||||||
|
|
||||||
|
* Thu May 18 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.3.0-1
|
||||||
|
- Update to 0.80.0
|
||||||
|
|
||||||
|
* Tue Mar 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.4-1
|
||||||
|
- Update to version 0.2.4; Fixes RHBZ#2176260
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 07 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.3-1
|
||||||
|
- Update to version 0.2.3; Fixes RHBZ#2140449
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.2.1-1
|
||||||
|
- Update to version 0.2.1; Fixes RHBZ#2097961
|
||||||
|
|
||||||
|
* Tue Apr 12 2022 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.2.0-1
|
||||||
|
- Initial Fedora package
|
Loading…
Reference in new issue