Update to 3.1.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 2b0b6cbe12
commit bc27c8ea96
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,3 +1,4 @@
/syntect-2.1.0.crate
/syntect-3.0.1.crate
/syntect-3.0.2.crate
/syntect-3.1.0.crate

@ -1,32 +0,0 @@
From 16da31ca8b0243fe9f9fafb3f511518540907e45 Mon Sep 17 00:00:00 2001
From: Tristan Hume <tris.hume@gmail.com>
Date: Tue, 29 Jan 2019 10:47:26 -0500
Subject: [PATCH] Update plist to v0.4
---
src/highlighting/settings.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/highlighting/settings.rs b/src/highlighting/settings.rs
index da64fcf..096c78a 100644
--- a/src/highlighting/settings.rs
+++ b/src/highlighting/settings.rs
@@ -3,7 +3,6 @@
use std::io::{Read, Seek};
use plist::{Error as PlistError};
-use plist::serde::deserialize;
pub use serde_json::Value as Settings;
pub use serde_json::Value::Array as SettingsArray;
@@ -33,6 +32,6 @@ impl From<PlistError> for SettingsError {
}
pub fn read_plist<R: Read + Seek>(reader: R) -> Result<Settings, SettingsError> {
- let settings = deserialize(reader)?;
+ let settings = plist::from_reader(reader)?;
Ok(settings)
}
--
2.20.1

@ -6,18 +6,13 @@
%global crate syntect
Name: rust-%{crate}
Version: 3.0.2
Release: 3%{?dist}
Version: 3.1.0
Release: 1%{?dist}
Summary: Library for high quality syntax highlighting and code intelligence
License: MIT
URL: https://crates.io/crates/syntect
Source: %{crates_source}
# Initial patched metadata
# * Bump plist to 0.4, https://github.com/trishume/syntect/pull/232
Patch0: syntect-fix-metadata.diff
# Make it work with new plist
Patch1: 0001-Update-plist-to-v0.4.patch
ExclusiveArch: %{rust_arches}
@ -41,7 +36,7 @@ BuildRequires: (crate(yaml-rust/default) >= 0.4.0 with crate(yaml-rust/default)
%if %{with check}
BuildRequires: (crate(criterion/default) >= 0.2.0 with crate(criterion/default) < 0.3.0)
BuildRequires: (crate(getopts/default) >= 0.2.0 with crate(getopts/default) < 0.3.0)
BuildRequires: (crate(pretty_assertions/default) >= 0.5.0 with crate(pretty_assertions/default) < 0.6.0)
BuildRequires: (crate(pretty_assertions/default) >= 0.6.0 with crate(pretty_assertions/default) < 0.7.0)
BuildRequires: (crate(rayon/default) >= 1.0.0 with crate(rayon/default) < 2.0.0)
BuildRequires: (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
%endif
@ -186,6 +181,18 @@ which use "html" feature of "%{crate}" crate.
%files -n %{name}+html-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+metadata-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+metadata-devel %{_description}
This package contains library source intended for building other packages
which use "metadata" feature of "%{crate}" crate.
%files -n %{name}+metadata-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+onig-devel
Summary: %{summary}
BuildArch: noarch
@ -262,6 +269,9 @@ which use "yaml-rust" feature of "%{crate}" crate.
%endif
%changelog
* Sun Feb 24 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.1.0-1
- Update to 3.1.0
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.2-3
- Bump plist to 0.4

@ -1 +1 @@
SHA512 (syntect-3.0.2.crate) = 3f8ad590a78f4f850560841980c7090de563c774ea128a35277b0a5b9ad922b6eff5f3bfedb07a1252d24e6e3cba08c8e5aa22cdf2a84107aad4cd3a135c75f6
SHA512 (syntect-3.1.0.crate) = 4b29ba3163d4ffc2aaa455f7911f1bea3c948ffb70d54b36ee3388f457796ee26e85d1907b2ef6ca4dfa4fdf2c70e20f108dfee47db571d898b07013dfc18fec

@ -1,11 +0,0 @@
--- syntect-3.0.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ syntect-3.0.2/Cargo.toml 2019-02-10T10:57:10.076065+01:00
@@ -61,7 +61,7 @@
optional = true
[dependencies.plist]
-version = "0.3"
+version = "0.4"
[dependencies.regex-syntax]
version = "0.6"
Loading…
Cancel
Save