Bump plist to 0.4

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 49e694e09f
commit 2b0b6cbe12
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -0,0 +1,32 @@
From 16da31ca8b0243fe9f9fafb3f511518540907e45 Mon Sep 17 00:00:00 2001
From: Tristan Hume <tris.hume@gmail.com>
Date: Tue, 29 Jan 2019 10:47:26 -0500
Subject: [PATCH] Update plist to v0.4
---
src/highlighting/settings.rs | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/src/highlighting/settings.rs b/src/highlighting/settings.rs
index da64fcf..096c78a 100644
--- a/src/highlighting/settings.rs
+++ b/src/highlighting/settings.rs
@@ -3,7 +3,6 @@
use std::io::{Read, Seek};
use plist::{Error as PlistError};
-use plist::serde::deserialize;
pub use serde_json::Value as Settings;
pub use serde_json::Value::Array as SettingsArray;
@@ -33,6 +32,6 @@ impl From<PlistError> for SettingsError {
}
pub fn read_plist<R: Read + Seek>(reader: R) -> Result<Settings, SettingsError> {
- let settings = deserialize(reader)?;
+ let settings = plist::from_reader(reader)?;
Ok(settings)
}
--
2.20.1

@ -7,12 +7,17 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 3.0.2 Version: 3.0.2
Release: 2%{?dist} Release: 3%{?dist}
Summary: Library for high quality syntax highlighting and code intelligence Summary: Library for high quality syntax highlighting and code intelligence
License: MIT License: MIT
URL: https://crates.io/crates/syntect URL: https://crates.io/crates/syntect
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source: %{crates_source}
# Initial patched metadata
# * Bump plist to 0.4, https://github.com/trishume/syntect/pull/232
Patch0: syntect-fix-metadata.diff
# Make it work with new plist
Patch1: 0001-Update-plist-to-v0.4.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -26,7 +31,7 @@ BuildRequires: (crate(fnv/default) >= 1.0.0 with crate(fnv/default) < 2.0.0)
BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0) BuildRequires: (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires: (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0) BuildRequires: (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0)
BuildRequires: (crate(onig/default) >= 4.1.0 with crate(onig/default) < 5.0.0) BuildRequires: (crate(onig/default) >= 4.1.0 with crate(onig/default) < 5.0.0)
BuildRequires: (crate(plist/default) >= 0.3.0 with crate(plist/default) < 0.4.0) BuildRequires: (crate(plist/default) >= 0.4.0 with crate(plist/default) < 0.5.0)
BuildRequires: (crate(regex-syntax/default) >= 0.6.0 with crate(regex-syntax/default) < 0.7.0) BuildRequires: (crate(regex-syntax/default) >= 0.6.0 with crate(regex-syntax/default) < 0.7.0)
BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0) BuildRequires: (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0) BuildRequires: (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
@ -242,7 +247,7 @@ which use "yaml-rust" feature of "%{crate}" crate.
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%build %build
@ -257,6 +262,9 @@ which use "yaml-rust" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.2-3
- Bump plist to 0.4
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2 * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -0,0 +1,11 @@
--- syntect-3.0.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ syntect-3.0.2/Cargo.toml 2019-02-10T10:57:10.076065+01:00
@@ -61,7 +61,7 @@
optional = true
[dependencies.plist]
-version = "0.3"
+version = "0.4"
[dependencies.regex-syntax]
version = "0.6"

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-syntect
Loading…
Cancel
Save