parent
ee02eeda9c
commit
6fd2224d94
@ -0,0 +1 @@
|
|||||||
|
/sval_flatten-2.10.2.crate
|
@ -0,0 +1,96 @@
|
|||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate sval_flatten
|
||||||
|
|
||||||
|
Name: rust-sval_flatten
|
||||||
|
Version: 2.10.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Value flattening for sval
|
||||||
|
|
||||||
|
License: Apache-2.0 OR MIT
|
||||||
|
URL: https://crates.io/crates/sval_flatten
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * add missing sval_derive_macros and sval_test dev-dependencies
|
||||||
|
Patch: sval_flatten-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Value flattening for sval.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+alloc-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+alloc-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "alloc" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+alloc-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (sval_flatten-2.10.2.crate) = 1a227e444ce522b8d1f94b5d285976399e701c8128afad2123d92fbe180a11953455fb98c561bec23735c178a3b30c303b7f035cadd498fa906af7282fb154a9
|
@ -0,0 +1,15 @@
|
|||||||
|
--- sval_flatten-2.10.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ sval_flatten-2.10.2/Cargo.toml 2023-11-03T12:20:08.398196+00:00
|
||||||
|
@@ -42,7 +42,11 @@
|
||||||
|
version = "2.10.2"
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[dev-dependencies]
|
||||||
|
+[dev-dependencies.sval_derive_macros]
|
||||||
|
+version = "2.10.2"
|
||||||
|
+
|
||||||
|
+[dev-dependencies.sval_test]
|
||||||
|
+version = "2.10.2"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
alloc = [
|
Loading…
Reference in new issue