Update to version 2.6.1; Fixes RHBZ#2181433

epel9
Fabio Valentini 2 years ago
parent 787238b7a0
commit afbec3c59a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -4,3 +4,4 @@
/sval-0.5.1.crate /sval-0.5.1.crate
/sval-0.5.2.crate /sval-0.5.2.crate
/sval-1.0.0-alpha.5.crate /sval-1.0.0-alpha.5.crate
/sval-2.6.1.crate

@ -1,3 +0,0 @@
# rust-sval
The rust-sval package

@ -1,27 +1,22 @@
# Generated by rust2rpm 22 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sval %global crate sval
Name: rust-sval Name: rust-sval
Version: 1.0.0~alpha.5 Version: 2.6.1
Release: %autorelease Release: %autorelease
Summary: No-std, object-safe serialization framework Summary: Streaming, structured value serialization
License: Apache-2.0 OR MIT License: Apache-2.0 OR MIT
URL: https://crates.io/crates/sval URL: https://crates.io/crates/sval
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused wasm-bindgen / wasm-binden-test dev-dependencies
Patch: sval-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: cargo-rpm-macros >= 24
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
No-std, object-safe serialization framework.} Streaming, structured value serialization.}
%description %{_description} %description %{_description}
@ -65,18 +60,6 @@ use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel %files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-depth-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-depth-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary-depth" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-depth-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive-devel %package -n %{name}+derive-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -89,66 +72,6 @@ use the "derive" feature of the "%{crate}" crate.
%files -n %{name}+derive-devel %files -n %{name}+derive-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fmt-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fmt-devel %{_description}
This package contains library source intended for building other packages which
use the "fmt" feature of the "%{crate}" crate.
%files -n %{name}+fmt-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde1-devel %{_description}
This package contains library source intended for building other packages which
use the "serde1" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1_lib-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde1_lib-devel %{_description}
This package contains library source intended for building other packages which
use the "serde1_lib" feature of the "%{crate}" crate.
%files -n %{name}+serde1_lib-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+smallvec-devel %{_description}
This package contains library source intended for building other packages which
use the "smallvec" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -161,46 +84,22 @@ use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sval_derive-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sval_derive-devel %{_description}
This package contains library source intended for building other packages which
use the "sval_derive" feature of the "%{crate}" crate.
%files -n %{name}+sval_derive-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test-devel %{_description}
This package contains library source intended for building other packages which
use the "test" feature of the "%{crate}" crate.
%files -n %{name}+test-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
%cargo_generate_buildrequires %cargo_generate_buildrequires -a
%build %build
%cargo_build %cargo_build -a
%install %install
%cargo_install %cargo_install -a
%if %{with check} %if %{with check}
%check %check
%cargo_test %cargo_test -a
%endif %endif
%changelog %changelog

@ -0,0 +1,2 @@
[DEFAULT]
all-features = true

@ -1 +1 @@
SHA512 (sval-1.0.0-alpha.5.crate) = 474fed7e9d31cb4f41e0a1baef24c91ec65b22370f6a40769e5079d5f7a6ba1e2403cfb033b1ba8d0252c04e4cb817c699ccc6fd0a7d36bdb07d4e3933c8180a SHA512 (sval-2.6.1.crate) = 15bbdbce7357a08ea618947ccb59818f3c3944dfa8b24bb22c23b75b42f30f235823dad441218d457d4c450824a59fd9a144133f35d106cd26c2ea152c898de5

@ -1,15 +0,0 @@
--- sval-1.0.0-alpha.5/Cargo.toml 2021-01-27T02:13:15+00:00
+++ sval-1.0.0-alpha.5/Cargo.toml 2022-08-01T10:35:03.170462+00:00
@@ -44,12 +44,6 @@
[dev-dependencies.quickcheck]
version = "0.9"
-[dev-dependencies.wasm-bindgen]
-version = "0.2"
-
-[dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
[features]
alloc = []
arbitrary-depth = ["alloc", "smallvec"]
Loading…
Cancel
Save