Drop unused wasm-bindgen dev-dependencies

epel9
Fabio Valentini 2 years ago
parent 93471769cc
commit 39e1c0489b
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,25 +1,24 @@
# Generated by rust2rpm 19
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate sval
Name: rust-%{crate}
Name: rust-sval
Version: 1.0.0~alpha.5
Release: %autorelease
Summary: No-std, object-safe serialization framework
# Upstream license specification: Apache-2.0 OR MIT
License: ASL 2.0 or MIT
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/sval
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused wasm-bindgen / wasm-binden-test dev-dependencies
Patch: sval-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
No-std, object-safe serialization framework.}
@ -33,12 +32,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use "%{crate}" crate.
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CODE_OF_CONDUCT.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -47,10 +48,10 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate.
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -59,10 +60,10 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use "the alloc" feature of the "%{crate}" crate.
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-depth-devel
Summary: %{summary}
@ -71,10 +72,10 @@ BuildArch: noarch
%description -n %{name}+arbitrary-depth-devel %{_description}
This package contains library source intended for building other packages which
use "the arbitrary-depth" feature of the "%{crate}" crate.
use the "arbitrary-depth" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-depth-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+derive-devel
Summary: %{summary}
@ -83,10 +84,10 @@ BuildArch: noarch
%description -n %{name}+derive-devel %{_description}
This package contains library source intended for building other packages which
use "the derive" feature of the "%{crate}" crate.
use the "derive" feature of the "%{crate}" crate.
%files -n %{name}+derive-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fmt-devel
Summary: %{summary}
@ -95,10 +96,10 @@ BuildArch: noarch
%description -n %{name}+fmt-devel %{_description}
This package contains library source intended for building other packages which
use "the fmt" feature of the "%{crate}" crate.
use the "fmt" feature of the "%{crate}" crate.
%files -n %{name}+fmt-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
@ -107,10 +108,10 @@ BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use "the serde" feature of the "%{crate}" crate.
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1-devel
Summary: %{summary}
@ -119,10 +120,10 @@ BuildArch: noarch
%description -n %{name}+serde1-devel %{_description}
This package contains library source intended for building other packages which
use "the serde1" feature of the "%{crate}" crate.
use the "serde1" feature of the "%{crate}" crate.
%files -n %{name}+serde1-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde1_lib-devel
Summary: %{summary}
@ -131,10 +132,10 @@ BuildArch: noarch
%description -n %{name}+serde1_lib-devel %{_description}
This package contains library source intended for building other packages which
use "the serde1_lib" feature of the "%{crate}" crate.
use the "serde1_lib" feature of the "%{crate}" crate.
%files -n %{name}+serde1_lib-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+smallvec-devel
Summary: %{summary}
@ -143,10 +144,10 @@ BuildArch: noarch
%description -n %{name}+smallvec-devel %{_description}
This package contains library source intended for building other packages which
use "the smallvec" feature of the "%{crate}" crate.
use the "smallvec" feature of the "%{crate}" crate.
%files -n %{name}+smallvec-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -155,10 +156,10 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use "the std" feature of the "%{crate}" crate.
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sval_derive-devel
Summary: %{summary}
@ -167,10 +168,10 @@ BuildArch: noarch
%description -n %{name}+sval_derive-devel %{_description}
This package contains library source intended for building other packages which
use "the sval_derive" feature of the "%{crate}" crate.
use the "sval_derive" feature of the "%{crate}" crate.
%files -n %{name}+sval_derive-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test-devel
Summary: %{summary}
@ -179,10 +180,10 @@ BuildArch: noarch
%description -n %{name}+test-devel %{_description}
This package contains library source intended for building other packages which
use "the test" feature of the "%{crate}" crate.
use the "test" feature of the "%{crate}" crate.
%files -n %{name}+test-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,15 @@
--- sval-1.0.0-alpha.5/Cargo.toml 2021-01-27T02:13:15+00:00
+++ sval-1.0.0-alpha.5/Cargo.toml 2022-08-01T10:35:03.170462+00:00
@@ -44,12 +44,6 @@
[dev-dependencies.quickcheck]
version = "0.9"
-[dev-dependencies.wasm-bindgen]
-version = "0.2"
-
-[dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
[features]
alloc = []
arbitrary-depth = ["alloc", "smallvec"]
Loading…
Cancel
Save