commit
7f94ef3cdc
@ -0,0 +1 @@
|
|||||||
|
SOURCES/strum-0.21.0.crate
|
@ -0,0 +1 @@
|
|||||||
|
a69ad34548c7f11b672ae6b53b4635a44ec6c255 SOURCES/strum-0.21.0.crate
|
@ -0,0 +1,5 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"remove reference to readme file that is not included in published crates",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,10 @@
|
|||||||
|
--- strum-0.21.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ strum-0.21.0/Cargo.toml 2024-09-14T14:17:30.666101+00:00
|
||||||
|
@@ -18,7 +18,6 @@
|
||||||
|
description = "Helpful macros for working with enums and strings"
|
||||||
|
homepage = "https://github.com/Peternator7/strum"
|
||||||
|
documentation = "https://docs.rs/strum"
|
||||||
|
-readme = "../README.md"
|
||||||
|
keywords = ["enum", "string", "macros", "proc-macros"]
|
||||||
|
categories = ["development-tools::procedural-macro-helpers", "parsing"]
|
||||||
|
license = "MIT"
|
@ -0,0 +1,131 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.2)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 8;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate strum
|
||||||
|
|
||||||
|
Name: rust-strum0.21
|
||||||
|
Version: 0.21.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Helpful macros for working with enums and strings
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/strum
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * remove reference to readme file that is not included in published crates
|
||||||
|
Patch: strum-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Helpful macros for working with enums and strings.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+derive-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+derive-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "derive" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+derive-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+strum_macros-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+strum_macros-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "strum_macros" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+strum_macros-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test -f derive
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.21.0-8
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Sep 14 2024 Fabio Valentini <decathorpe@gmail.com> - 0.21.0-8
|
||||||
|
- Remove reference to readme file that is not included in published crates
|
||||||
|
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.21.0-5
|
||||||
|
- Regenerate with rust2rpm v24
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.21.0-1
|
||||||
|
- Initial import (strum 0.21 compat package)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue