i10ce
changed/i10ce/rust-strip-ansi-escapes0.1-0.1.1-4.el10
commit
28dcd46b81
@ -0,0 +1 @@
|
|||||||
|
SOURCES/strip-ansi-escapes-0.1.1.crate
|
@ -0,0 +1 @@
|
|||||||
|
253bd07136d2c33dc1cf7d476ceb4f74a1ec0f3d SOURCES/strip-ansi-escapes-0.1.1.crate
|
@ -0,0 +1,8 @@
|
|||||||
|
--- strip-ansi-escapes-0.1.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||||
|
+++ strip-ansi-escapes-0.1.1/Cargo.toml 2023-12-22T23:41:07.970958+00:00
|
||||||
|
@@ -22,4 +22,4 @@
|
||||||
|
license = "Apache-2.0/MIT"
|
||||||
|
repository = "https://github.com/luser/strip-ansi-escapes"
|
||||||
|
[dependencies.vte]
|
||||||
|
-version = "0.10"
|
||||||
|
+version = "0.13"
|
@ -0,0 +1,98 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.1)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 4;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate strip-ansi-escapes
|
||||||
|
|
||||||
|
Name: rust-strip-ansi-escapes0.1
|
||||||
|
Version: 0.1.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Strip ANSI escape sequences from byte streams
|
||||||
|
|
||||||
|
# Upstream license specification: Apache-2.0/MIT
|
||||||
|
License: Apache-2.0 OR MIT
|
||||||
|
URL: https://crates.io/crates/strip-ansi-escapes
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump vte dependency from 0.10 to 0.13
|
||||||
|
Patch: strip-ansi-escapes-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Strip ANSI escape sequences from byte streams.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.1-4
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Dec 22 2023 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.1.1-2
|
||||||
|
- Rebuilt for vte 0.13
|
||||||
|
|
||||||
|
* Sat Oct 14 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.1-1
|
||||||
|
- Initial import (strip-ansi-escapes 0.1 compat package)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue