parent
163da79f87
commit
72ea707585
@ -0,0 +1 @@
|
|||||||
|
/statistical-0.1.1.crate
|
@ -0,0 +1,74 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
# * Tests are run in infrastructure
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate statistical
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Simple statistics library
|
||||||
|
|
||||||
|
# License is in the repo, but no new version has been published yet
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/statistical
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Update dependencies, https://github.com/JeffBelgum/statistical/pull/14
|
||||||
|
Patch0: statistical-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
BuildRequires: (crate(num/default) >= 0.2.0 with crate(num/default) < 0.3.0)
|
||||||
|
BuildRequires: (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
A simple statistics library.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 28 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.1-1
|
||||||
|
- Initial package
|
@ -0,0 +1 @@
|
|||||||
|
SHA512 (statistical-0.1.1.crate) = 0608aaedabfab7e269c9e559a0bf09f9ef2ae882f5e42c8766b82323a593ea88eba745ad6fc6b4f800b352554eeff8075d1979029a51b8e616b4bb2759050c26
|
@ -0,0 +1,10 @@
|
|||||||
|
--- statistical-0.1.1/Cargo.toml 2015-08-11T22:44:37+02:00
|
||||||
|
+++ statistical-0.1.1/Cargo.toml 2019-01-28T16:18:30.675878+01:00
|
||||||
|
@@ -13,5 +13,5 @@
|
||||||
|
keywords = ["statistics", "statistical", "analysis", "math", "algorithm"]
|
||||||
|
|
||||||
|
[dependencies]
|
||||||
|
-rand = "0.3.7"
|
||||||
|
-num = "0.1.23"
|
||||||
|
+rand = "0.6"
|
||||||
|
+num = "0.2"
|
@ -0,0 +1 @@
|
|||||||
|
1
|
@ -0,0 +1,5 @@
|
|||||||
|
---
|
||||||
|
standard-inventory-qcow2:
|
||||||
|
qemu:
|
||||||
|
# `cargo test` usually eats more than 1G.
|
||||||
|
m: 4G
|
@ -0,0 +1,13 @@
|
|||||||
|
---
|
||||||
|
- hosts: localhost
|
||||||
|
roles:
|
||||||
|
- role: standard-test-basic
|
||||||
|
tags:
|
||||||
|
- classic
|
||||||
|
repositories:
|
||||||
|
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||||
|
dest: rust
|
||||||
|
tests:
|
||||||
|
- rust/cargo-test
|
||||||
|
environment:
|
||||||
|
pkg: rust-statistical
|
Loading…
Reference in new issue