parent
0a0300dc90
commit
ca7a99665b
@ -0,0 +1 @@
|
|||||||
|
/socket2-0.3.0.crate
|
@ -0,0 +1,66 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate socket2
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.3.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Utilities for handling networking sockets
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/socket2
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * No windows
|
||||||
|
Patch0: socket2-0.3.0-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(cfg-if) >= 0.1.0 with crate(cfg-if) < 0.2.0)
|
||||||
|
BuildRequires: (crate(libc) >= 0.2.14 with crate(libc) < 0.3.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Utilities for handling networking sockets with a maximal amount of
|
||||||
|
configuration possible intended.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
|
||||||
|
- Initial package
|
@ -0,0 +1,9 @@
|
|||||||
|
--- socket2-0.3.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ socket2-0.3.0/Cargo.toml 2018-01-13T17:44:09.664288+01:00
|
||||||
|
@@ -34,6 +34,3 @@
|
||||||
|
|
||||||
|
[target."cfg(unix)".dependencies.libc]
|
||||||
|
version = "0.2.14"
|
||||||
|
-[target."cfg(windows)".dependencies.winapi]
|
||||||
|
-version = "0.3"
|
||||||
|
-features = ["handleapi", "ws2def", "ws2ipdef", "ws2tcpip", "minwindef"]
|
Loading…
Reference in new issue