import rust-snapbox-0.6.20-1.el10

i10ce changed/i10ce/rust-snapbox-0.6.20-1.el10
MSVSphere Packaging Team 2 months ago
commit 4c12ca46f9
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/snapbox-0.6.20.crate

@ -0,0 +1 @@
8534a8a0c6f31b8c86e7b36e9bfe6958aeed8dfd SOURCES/snapbox-0.6.20.crate

@ -0,0 +1,3 @@
[package]
cargo-install-bin = false

@ -0,0 +1,27 @@
--- snapbox-0.6.20/Cargo.toml 1970-01-01T00:00:01+00:00
+++ snapbox-0.6.20/Cargo.toml 2024-11-09T19:49:11.111491+00:00
@@ -189,7 +189,6 @@
"dep:os_pipe",
"dep:wait-timeout",
"dep:libc",
- "dep:windows-sys",
]
color = [
"dep:anstream",
@@ -229,11 +228,6 @@
[target."cfg(unix)".dependencies.libc]
version = "0.2.137"
-optional = true
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.59.0"
-features = ["Win32_Foundation"]
optional = true
[lints.clippy]
@@ -306,3 +300,4 @@
[lints.rust.rust_2018_idioms]
level = "warn"
priority = -1
+

@ -0,0 +1,291 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
# prevent executables from being installed
%global cargo_install_bin 0
%global crate snapbox
Name: rust-snapbox
Version: 0.6.20
Release: %autorelease
Summary: Snapshot testing toolbox
License: MIT OR Apache-2.0
URL: https://crates.io/crates/snapbox
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: snapbox-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 26
%global _description %{expand:
Snapshot testing toolbox.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cmd-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cmd-devel %{_description}
This package contains library source intended for building other packages which
use the "cmd" feature of the "%{crate}" crate.
%files -n %{name}+cmd-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+color-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+color-devel %{_description}
This package contains library source intended for building other packages which
use the "color" feature of the "%{crate}" crate.
%files -n %{name}+color-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+color-auto-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+color-auto-devel %{_description}
This package contains library source intended for building other packages which
use the "color-auto" feature of the "%{crate}" crate.
%files -n %{name}+color-auto-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+debug-devel %{_description}
This package contains library source intended for building other packages which
use the "debug" feature of the "%{crate}" crate.
%files -n %{name}+debug-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+detect-encoding-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+detect-encoding-devel %{_description}
This package contains library source intended for building other packages which
use the "detect-encoding" feature of the "%{crate}" crate.
%files -n %{name}+detect-encoding-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+diff-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+diff-devel %{_description}
This package contains library source intended for building other packages which
use the "diff" feature of the "%{crate}" crate.
%files -n %{name}+diff-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dir-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dir-devel %{_description}
This package contains library source intended for building other packages which
use the "dir" feature of the "%{crate}" crate.
%files -n %{name}+dir-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+examples-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+examples-devel %{_description}
This package contains library source intended for building other packages which
use the "examples" feature of the "%{crate}" crate.
%files -n %{name}+examples-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+json-devel %{_description}
This package contains library source intended for building other packages which
use the "json" feature of the "%{crate}" crate.
%files -n %{name}+json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+path-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+path-devel %{_description}
This package contains library source intended for building other packages which
use the "path" feature of the "%{crate}" crate.
%files -n %{name}+path-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+regex-devel %{_description}
This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+structured-data-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+structured-data-devel %{_description}
This package contains library source intended for building other packages which
use the "structured-data" feature of the "%{crate}" crate.
%files -n %{name}+structured-data-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+term-svg-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+term-svg-devel %{_description}
This package contains library source intended for building other packages which
use the "term-svg" feature of the "%{crate}" crate.
%files -n %{name}+term-svg-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.6.20-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sat Nov 09 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.20-1
- Update to version 0.6.20; Fixes RHBZ#2322525
* Fri Oct 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.18-1
- Update to version 0.6.18; Fixes RHBZ#2316413
* Tue Sep 17 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.17-1
- Update to version 0.6.17; Fixes RHBZ#2305034
* Sun Aug 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.16-1
- Update to version 0.6.16; Fixes RHBZ#2296998
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Mon Jun 10 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.10-1
- Update to version 0.6.10
* Mon Jun 10 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.9-1
- Update to version 0.6.9; Fixes RHBZ#2263408
* Mon Jun 10 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.7-1
- Update to version 0.6.7
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Jan 13 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.16-1
- Update to version 0.4.16; Fixes RHBZ#2258000
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.15-1
- Update to version 0.4.15; Fixes RHBZ#2253694
* Wed Nov 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.14-1
- Initial import (#2246008)
## END: Generated by rpmautospec
Loading…
Cancel
Save