commit
3f009e278c
Binary file not shown.
@ -0,0 +1,18 @@
|
|||||||
|
--- snapbox-0.4.15/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ snapbox-0.4.15/Cargo.toml 2024-01-11T20:05:56.866668+00:00
|
||||||
|
@@ -165,7 +165,6 @@
|
||||||
|
"dep:os_pipe",
|
||||||
|
"dep:wait-timeout",
|
||||||
|
"dep:libc",
|
||||||
|
- "dep:windows-sys",
|
||||||
|
]
|
||||||
|
color = [
|
||||||
|
"dep:anstream",
|
||||||
|
@@ -204,7 +203,3 @@
|
||||||
|
version = "0.2.137"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dependencies.windows-sys]
|
||||||
|
-version = "0.52.0"
|
||||||
|
-features = ["Win32_Foundation"]
|
||||||
|
-optional = true
|
@ -0,0 +1,20 @@
|
|||||||
|
--- snapbox-0.4.15/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ snapbox-0.4.15/Cargo.toml 2024-01-11T20:06:08.434705+00:00
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
categories = ["development-tools::testing"]
|
||||||
|
license = "MIT OR Apache-2.0"
|
||||||
|
repository = "https://github.com/assert-rs/trycmd/"
|
||||||
|
+autobins = false
|
||||||
|
|
||||||
|
[package.metadata.docs.rs]
|
||||||
|
all-features = true
|
||||||
|
@@ -82,9 +83,6 @@
|
||||||
|
<!-- next-url -->
|
||||||
|
[Unreleased]: https://github.com/assert-rs/trycmd/compare/{{tag_name}}...HEAD"""
|
||||||
|
search = "<!-- next-url -->"
|
||||||
|
-
|
||||||
|
-[[bin]]
|
||||||
|
-name = "snap-fixture"
|
||||||
|
|
||||||
|
[[example]]
|
||||||
|
name = "diff"
|
@ -0,0 +1,235 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate snapbox
|
||||||
|
|
||||||
|
Name: rust-snapbox
|
||||||
|
Version: 0.4.15
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Snapshot testing toolbox
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/snapbox
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip dependencies and normalize metadata
|
||||||
|
Patch: snapbox-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * prevent test-only snap-fixture binary from being built and shipped
|
||||||
|
Patch: snapbox-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Snapshot testing toolbox.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+cmd-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+cmd-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "cmd" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+cmd-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+color-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+color-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "color" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+color-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+color-auto-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+color-auto-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "color-auto" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+color-auto-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+debug-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+debug-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "debug" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+debug-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+detect-encoding-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+detect-encoding-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "detect-encoding" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+detect-encoding-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+diff-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+diff-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "diff" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+diff-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+document-features-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+document-features-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "document-features" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+document-features-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+examples-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+examples-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "examples" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+examples-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+harness-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+harness-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "harness" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+harness-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+json-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+json-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "json" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+json-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+path-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+path-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "path" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+path-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+structured-data-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+structured-data-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "structured-data" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+structured-data-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.15-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Thu Jan 11 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.15-1
|
||||||
|
- Update to version 0.4.15; Fixes RHBZ#2253694
|
||||||
|
|
||||||
|
* Wed Nov 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.14-1
|
||||||
|
- Initial import (#2246008)
|
Loading…
Reference in new issue