commit
77850a2a2a
@ -0,0 +1 @@
|
|||||||
|
SOURCES/smol_str-0.3.2.crate
|
@ -0,0 +1 @@
|
|||||||
|
9a8b3bd0e0386ce4a04c6fe2a2b68cdd511bd36e SOURCES/smol_str-0.3.2.crate
|
@ -0,0 +1,10 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused optional support for borsh",
|
||||||
|
]
|
||||||
|
|
||||||
|
[tests]
|
||||||
|
skip = ["check_code_formatting"]
|
||||||
|
skip-exact = true
|
||||||
|
comments = ["skip a test that requires running rustfmt"]
|
||||||
|
|
@ -0,0 +1,20 @@
|
|||||||
|
--- smol_str-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ smol_str-0.3.2/Cargo.toml 2024-12-02T17:27:50.402886+00:00
|
||||||
|
@@ -50,11 +50,6 @@
|
||||||
|
version = "1.3"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
-[dependencies.borsh]
|
||||||
|
-version = "1.4.0"
|
||||||
|
-optional = true
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[dependencies.serde]
|
||||||
|
version = "1.0"
|
||||||
|
optional = true
|
||||||
|
@@ -74,5 +69,4 @@
|
||||||
|
default = ["std"]
|
||||||
|
std = [
|
||||||
|
"serde?/std",
|
||||||
|
- "borsh?/std",
|
||||||
|
]
|
@ -0,0 +1,159 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 27
|
||||||
|
%bcond check 1
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate smol_str
|
||||||
|
|
||||||
|
Name: rust-smol_str
|
||||||
|
Version: 0.3.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Small-string optimized string type with O(1) clone
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/smol_str
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused optional support for borsh
|
||||||
|
Patch: smol_str-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Small-string optimized string type with O(1) clone.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+arbitrary-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+arbitrary-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "arbitrary" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+arbitrary-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
# * skip a test that requires running rustfmt
|
||||||
|
%cargo_test -- -- --exact --skip check_code_formatting
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.3.2-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Mon Dec 02 2024 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-1
|
||||||
|
- Update to version 0.3.2; Fixes RHBZ#2309365
|
||||||
|
|
||||||
|
* Wed Oct 23 2024 Fabio Valentini <decathorpe@gmail.com> - 0.2.2-1
|
||||||
|
- Update to version 0.2.2
|
||||||
|
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 0.2.1-1
|
||||||
|
- Update to version 0.2.1; Fixes RHBZ#2258569
|
||||||
|
|
||||||
|
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Sep 13 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.0-1
|
||||||
|
- Update to version 0.2.0; Fixes RHBZ#2185886
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.24-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Feb 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.24-1
|
||||||
|
- Update to version 0.1.24; Fixes RHBZ#2167153
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.23-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.23-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 12 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.23-1
|
||||||
|
- Update to version 0.1.23; Fixes RHBZ#2073568
|
||||||
|
|
||||||
|
* Sat Feb 05 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.21-1
|
||||||
|
- Initial import (#2050967)
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue