Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>epel9 imports/e9/rust-smartstring-1.0.1-1.el9
parent
936e26ea9b
commit
dc2fdf776c
@ -0,0 +1 @@
|
||||
/smartstring-1.0.1.crate
|
@ -0,0 +1,133 @@
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate smartstring
|
||||
|
||||
Name: rust-smartstring
|
||||
Version: 1.0.1
|
||||
Release: %autorelease
|
||||
Summary: Compact inlined strings
|
||||
|
||||
License: MPL-2.0+
|
||||
URL: https://crates.io/crates/smartstring
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# - drop benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: smartstring-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Compact inlined strings.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENCE.md
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+arbitrary-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+arbitrary-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "arbitrary" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+arbitrary-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+proptest-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+proptest-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "proptest" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+proptest-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+test-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+test-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "test" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+test-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,11 @@
|
||||
--- smartstring-1.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ smartstring-1.0.1/Cargo.toml 2022-12-20T22:19:00.675361+00:00
|
||||
@@ -45,8 +45,6 @@
|
||||
|
||||
[dependencies.static_assertions]
|
||||
version = "1"
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
|
||||
[dev-dependencies.proptest]
|
||||
version = "1"
|
Loading…
Reference in new issue