Bump glob to 0.3

Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
epel9
Robert-André Mauchin 6 years ago
parent 99225d08fd
commit 89c13c0590

@ -1,12 +1,12 @@
# Generated by rust2rpm # Generated by rust2rpm 10
%bcond_with check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate skeptic %global crate skeptic
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.13.4 Version: 0.13.4
Release: 2%{?dist} Release: 1%{?dist}
Summary: Test your Rust markdown documentation via Cargo Summary: Test your Rust markdown documentation via Cargo
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
@ -15,26 +15,19 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/skeptic URL: https://crates.io/crates/skeptic
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Update bytecount to 0.5, https://github.com/budziq/rust-skeptic/pull/95 # * Update bytecount to 0.5 (upstreamed)
# * Update glob to 0.3 (upstreamed)
Patch0: skeptic-fix-metadata.diff Patch0: skeptic-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(bytecount/default) >= 0.5.0 with crate(bytecount/default) < 0.6.0)
BuildRequires: (crate(cargo_metadata/default) >= 0.6.0 with crate(cargo_metadata/default) < 0.7.0)
BuildRequires: (crate(error-chain) >= 0.12.0 with crate(error-chain) < 0.13.0)
BuildRequires: (crate(glob/default) >= 0.2.0 with crate(glob/default) < 0.3.0)
BuildRequires: (crate(pulldown-cmark) >= 0.2.0 with crate(pulldown-cmark) < 0.3.0)
BuildRequires: (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
BuildRequires: (crate(tempdir/default) >= 0.3.0 with crate(tempdir/default) < 0.4.0)
BuildRequires: (crate(walkdir/default) >= 2.2.0 with crate(walkdir/default) < 3.0.0)
%if %{with check}
BuildRequires: (crate(unindent/default) >= 0.1.0 with crate(unindent/default) < 0.2.0)
%endif
%global _description \ %global _description %{expand:
Test your Rust markdown documentation via Cargo. Test your Rust markdown documentation via Cargo.}
%description %{_description} %description %{_description}
@ -67,6 +60,9 @@ which use "default" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -79,6 +75,9 @@ which use "default" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Wed Jul 31 19:54:43 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.13.4-3
- Bump glob to 0.3
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-2 * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1,5 +1,5 @@
--- skeptic-0.13.4/Cargo.toml 1970-01-01T01:00:00+01:00 --- skeptic-0.13.4/Cargo.toml 1970-01-01T00:00:00+00:00
+++ skeptic-0.13.4/Cargo.toml 2019-03-13T17:58:11.778083+01:00 +++ skeptic-0.13.4/Cargo.toml 2019-07-31T17:54:43.231811+00:00
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
name = "skeptic" name = "skeptic"
path = "lib.rs" path = "lib.rs"
@ -9,3 +9,12 @@
[dependencies.cargo_metadata] [dependencies.cargo_metadata]
version = "0.6" version = "0.6"
@@ -37,7 +37,7 @@
default-features = false
[dependencies.glob]
-version = "0.2"
+version = "0.3"
[dependencies.pulldown-cmark]
version = "0.2"

Loading…
Cancel
Save