commit
61a66efbb7
@ -0,0 +1,40 @@
|
|||||||
|
From df60bb467d13d6d1d04d302bc5c0c4b3ce955789 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Sat, 20 May 2023 17:24:33 +0200
|
||||||
|
Subject: [PATCH] port to cargo_metadata 0.15
|
||||||
|
|
||||||
|
---
|
||||||
|
src/rt.rs | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/rt.rs b/src/rt.rs
|
||||||
|
index 4c59754..7d4b9c5 100644
|
||||||
|
--- a/src/rt.rs
|
||||||
|
+++ b/src/rt.rs
|
||||||
|
@@ -5,9 +5,9 @@ use std::ffi::OsStr;
|
||||||
|
use std::fs;
|
||||||
|
use std::path::{Path, PathBuf};
|
||||||
|
use std::process::Command;
|
||||||
|
-use std::str::FromStr;
|
||||||
|
use std::time::SystemTime;
|
||||||
|
|
||||||
|
+use cargo_metadata::Edition;
|
||||||
|
use error_chain::error_chain;
|
||||||
|
use walkdir::WalkDir;
|
||||||
|
|
||||||
|
@@ -76,10 +76,10 @@ fn handle_test(
|
||||||
|
.packages
|
||||||
|
.iter()
|
||||||
|
.map(|package| &package.edition)
|
||||||
|
- .max_by_key(|edition| u64::from_str(edition).unwrap())
|
||||||
|
+ .max_by_key(|edition| *edition)
|
||||||
|
.unwrap()
|
||||||
|
.clone();
|
||||||
|
- if edition != "2015" {
|
||||||
|
+ if edition != Edition::E2015 {
|
||||||
|
cmd.arg(format!("--edition={}", edition));
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.40.1
|
||||||
|
|
Binary file not shown.
@ -0,0 +1,11 @@
|
|||||||
|
--- skeptic-0.13.7/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ skeptic-0.13.7/Cargo.toml 2023-05-20T15:20:26.554151+00:00
|
||||||
|
@@ -25,7 +25,7 @@
|
||||||
|
version = "0.6"
|
||||||
|
|
||||||
|
[dependencies.cargo_metadata]
|
||||||
|
-version = "0.14"
|
||||||
|
+version = "0.15"
|
||||||
|
|
||||||
|
[dependencies.error-chain]
|
||||||
|
version = "0.12"
|
@ -0,0 +1,142 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
# * files required by tests are not included in published crates
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate skeptic
|
||||||
|
|
||||||
|
Name: rust-skeptic
|
||||||
|
Version: 0.13.7
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Test your Rust markdown documentation via Cargo
|
||||||
|
|
||||||
|
# Upstream license specification: MIT/Apache-2.0
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/skeptic
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * bump cargo_metadata dependency from ^0.14 to ^0.15
|
||||||
|
Patch: skeptic-fix-metadata.diff
|
||||||
|
Patch: 0001-port-to-cargo_metadata-0.15.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Test your Rust markdown documentation via Cargo.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.13.7-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Sat May 20 2023 Fabio Valentini <decathorpe@gmail.com> - 0.13.7-1
|
||||||
|
- Update to version 0.13.7; Fixes RHBZ#2049074
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.6-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.6-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Mar 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.13.6-1
|
||||||
|
- Update to version 0.13.6.
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Dec 25 12:18:32 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.13.5-1
|
||||||
|
- Update to 0.13.5
|
||||||
|
|
||||||
|
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-10
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 22 19:15:34 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.13.4-8
|
||||||
|
- Update pulldown-cmark to 0.7
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Dec 15 15:00:04 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.13.4-6
|
||||||
|
- Bump cargo_metadata to 0.9
|
||||||
|
|
||||||
|
* Fri Sep 13 17:49:45 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.13.4-5
|
||||||
|
- Bump bytecount to 0.6
|
||||||
|
- Bump pulldown-cmark to 0.6
|
||||||
|
|
||||||
|
* Thu Aug 01 00:51:23 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.13.4-4
|
||||||
|
- Update 0001-Bump-cargo_metadata-to-0.8 patch
|
||||||
|
|
||||||
|
* Wed Jul 31 19:54:43 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.13.4-3
|
||||||
|
- Bump glob to 0.3 and cargo_metadata to 0.8
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.4-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue