parent
470f8e97ee
commit
a349700005
@ -0,0 +1 @@
|
|||||||
|
/simplelog-0.11.2.crate
|
@ -0,0 +1,121 @@
|
|||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate simplelog
|
||||||
|
|
||||||
|
Name: rust-simplelog0.11
|
||||||
|
Version: 0.11.2
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Simple and easy-to-use logging facility for Rust's log crate
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/simplelog
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * normalize dependencies to not be stricter than semver-compatibility
|
||||||
|
Patch: simplelog-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A simple and easy-to-use logging facility for Rust's log crate.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE.APACHE2
|
||||||
|
%license %{crate_instdir}/LICENSE.MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+ansi_term-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+ansi_term-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "ansi_term" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+ansi_term-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+paris-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+paris-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "paris" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+paris-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+termcolor-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+termcolor-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "termcolor" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+termcolor-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+test-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+test-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "test" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+test-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,21 @@
|
|||||||
|
--- simplelog-0.11.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ simplelog-0.11.2/Cargo.toml 2023-07-18T17:45:06.616541+00:00
|
||||||
|
@@ -29,15 +29,15 @@
|
||||||
|
version = "0.4.1"
|
||||||
|
|
||||||
|
[dependencies.log]
|
||||||
|
-version = "0.4.*"
|
||||||
|
+version = "0.4"
|
||||||
|
features = ["std"]
|
||||||
|
|
||||||
|
[dependencies.paris]
|
||||||
|
-version = "~1.5"
|
||||||
|
+version = "1.5"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
[dependencies.termcolor]
|
||||||
|
-version = "1.1.*"
|
||||||
|
+version = "1.1"
|
||||||
|
optional = true
|
||||||
|
|
||||||
|
[features]
|
Loading…
Reference in new issue